Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently updated my netbook (Asus 1005px) running ubuntu 10.10. The update came with a newer kernel. And it causes the system to freeze. Randomly the screen goes off, and I have to do a force shutdown. I tried selecting older kernel in the grub menu and it works fine. Now I want to set the older kernel as default, or I want to get rid of the new kernel. What is the best way of doing this?

share|improve this question

closed as off-topic by Braiam, Fabby, david6, Charles Green, Eric Carvalho Jan 31 at 18:26

This question appears to be off-topic. The users who voted to close gave these specific reasons:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
Please don't forget to open a bug report for your problem with the newer kernel. – João Pinto Nov 27 '10 at 16:45
    
how to report a linux kernel bug -> wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies – hhlp Feb 23 '11 at 20:02
up vote 1 down vote accepted

Boot into the kernel you want to keep and run:

sudo aptitude hold linux-image-`uname -r` linux-image

You might have to remove the newer kernel version manually. You can see what's installed with this:

dpkg -l | grep linux-image

And then

sudo apt-get remove linux-image-version-blah

Alternatively, you can do most of this by clicking around in Synaptic which might be a preferred option if you're not sure what you're doing.

share|improve this answer

i have same hardware and same problem. For me 2.6.36 maverick kernel fix the problem http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.36-maverick/

share|improve this answer
    
search keywords: 1005pe ubuntu 10 maverick freeze randomly. If that kernel version fix your problem, give me to know please – senionis Dec 16 '10 at 22:31

I installed the native nvidia graphics driver, and it solved the same problem for me on Ubuntu 10.10 / 64 bits desktop (System / Administration / Additional drivers)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.