Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed Ubuntu using WUBI, when I reboot, I'm able to login as "Failsafe GNOME" and xterm, but NOT as just GNOME. What is the likely source of the issue? Hardware, bad install, etc.?

  • Version: Ubuntu 10.04.1 LTS (Lucid Lynx)
  • WUBI (on Windows XP Pro SP3, basically all updates)
  • HARDWARE: PowerSpec 6245, Processor: AMD Athlon™ XP processor 2800+

When I login as GNOME, it takes the username/password, then screen goes black for 1-second, then flashes back to the login. At first I thought I forgot the admin password, but figured out I was able to login as xterm, then as Failsafe GNOME.

Any suggests? Thanks!

UPDATE (1):

From Failsafe, I'm able to change the default screen size/Hz (which is correct for the monitor) to 800x600, and then login as GNOME. If I change it back to the default via GNOME, I'm not able to login.

UPDATE (2):

Posted a follow up question focus on possible WUBI resource conflicts here. And info on a strange issue related to how changing the screen background results in the same pattern of the login failing.

UPDATE (3):

Given up on Ubuntu, don't have time for this, would delete the question, but there's too many answers. So, I'll just leave it unanswered.

share|improve this question
    
@Jorge Castro: Thanks for the edit. –  blunders Nov 27 '10 at 0:38

5 Answers 5

Try renaming ~/.gnome2/session to something else

share|improve this answer
    
under "/home/<user_name>/.gnome2/" there was the following after selecting "View > Show Hidden Files": accels/ , gedit/, keyrings/, nautilus-scripts/, panel2.d/, backgrounds.xml –  blunders Nov 27 '10 at 13:39
    
Does that mean I need to manually create a "session" file, and if so, how? Thanks! –  blunders Nov 27 '10 at 13:40
    
+1, finally got the points to up vote. –  blunders Nov 27 '10 at 14:49

Maybe Your Vga Card Isnot installed.. in the Gnome Panel Click System > Administration > Additional Software, it'll be loading for a few seconds then if u find any drivers in the window install them then restart your ubuntu.

share|improve this answer
    
+1 Does that require an internet connection? If so, that's fine, just need to know, since I haven't setup ndiswrapper for my WiFi adapter yet; which would mean I need that setup before I try, or not if it's not required. I do think it's related to the graphics library and my Integrated UniChrome KM400 videocard; likely just need to disable something, or manually set a screen config. –  blunders Nov 27 '10 at 12:50
    
Oops, "Vote Up requires 15 reputation" ...oh, well - I'll just up vote your answer later. –  blunders Nov 27 '10 at 12:51
    
"System > Administration > Additional Software" did not exist as an option, what else might it be called? –  blunders Nov 27 '10 at 13:38
    
+1, finally got the points to up vote. –  blunders Nov 27 '10 at 14:49

This behavior sounds like your user's GNOME profile is messed up. Have you been able to log in even once? In other words, was it working and stopped working or has it never worked?

share|improve this answer
    
Yes, I'm able to login to FailSafe, lower the default screensize,logout, then login to GNOME; meaning I can't without changing the screensize 1st. Also, noticed that if I'm in GNOME (not FailSafe) that if I change the desktop background from the default to solid color, logout, I can't log back in until I go into FailSafe and revert the desktop background to the default. Really think this is odd. Had seen some weird log under the sysLogs saying something about WUBI needing file sharing access; though went back later to find it and copy it to a text file and was unable to find it. –  blunders Nov 28 '10 at 2:51
    
+1 by the way, also under "/home/<user_name>/.gnome2/" there was the following after selecting "View > Show Hidden Files": accels/ , gedit/, keyrings/, nautilus-scripts/, panel2.d/, backgrounds.xml -- there is no "session" file... –  blunders Nov 28 '10 at 2:52
    
@blunders Add all this information to your question please so it doesn't get buried in comments. (as you keep investigating just keep updating your question so we keep getting more and more detail.) –  Jorge Castro Nov 28 '10 at 2:54

I encountered a similar issue, after having removed my desktop background image and chose to only use a solid color background. Then, when I tried to log in, after typing the password, I could see the desktop for about 1 second and then it went back to the login screen. I could log in as other users (who had set desktop background images). I could see some error messages from compiz (though I have never enabled any effects) in .xsession-errors.old and .xsession-errors. So what I did was to log in using fail safe Gnome, then choose a desktop background and everything was back to normal. I hope this helps; it's a quick thing to do anyway.

Regards, Mihai

share|improve this answer
    
+1 @MihaiH: Thanks, while I don't have it setup to try any more, or sure that I would be able to duplicate the setup I had then -- that said, I agree that it's very possible the possible that might have been the issue and solved the issue too. –  blunders Jan 14 '12 at 13:41
up vote -1 down vote accepted

Effort to answer this was abandoned, thus there is no correct answer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.