Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a new battery for my laptop a week ago and it worked fine up until last night when it wouldn't boot up. I plugged in the power lead and it booted but upon booting the battery status indicator shows "not present" even though it most definitely is.

dmesg | grep battery

[    0.412399] ACPI: Deprecated procfs I/F for battery is loaded, please retry with CONFIG_ACPI_PROCFS_POWER cleared
[    0.412411] ACPI: Battery Slot [BAT1] (battery present)
[    0.660147] [Firmware Bug]: battery: (dis)charge rate invalid.
[    0.660207] ACPI: Battery Slot [BAT1] (battery present)

cat /proc/acpi/battery/BAT1/info

present:                 yes
design capacity:         4400 mAh
last full capacity:      3497 mAh
battery technology:      rechargeable
design voltage:          10800 mV
design capacity warning: 340 mAh
design capacity low:     102 mAh
cycle count:          0
capacity granularity 1:  264 mAh
capacity granularity 2:  3780 mAh
model number:            
serial number:           41167
battery type:            Li-Ion
OEM info:                TOSHIBA

cat /proc/acpi/battery/BAT1/state

present:                 yes
capacity state:          ok
charging state:          charging
present rate:            2 mA
remaining capacity:      0 mAh
present voltage:         10447 mV

So I'm a little confused as some things are telling me its there and charging and others are not. Either way the battery is no longer holding charge because if I pull the power lead it turns off immediately.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Restart your laptop with different OSes. If Windows or Mac OS does not find any batteries, it is a hardware problem - with your battery, your battery "jack" (the part that takes power from the battery and feed it to the computer), or the connection. Reinsert your battery. If not working, request a warranty.

share|improve this answer
    
I re-installed Windows 7 in some spare space and updated all the drivers but still no joy. I've logged a fault with the store I purchased it from so I can get a replacement - just seemed odd that it failed so quickly. –  kemra102 Jun 23 '12 at 19:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.