Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install NetBeans 7.2 from a downloaded .sh file, but experienced problems. Here's text from the Terminal, which shows what I did and what happened:

hridesh@ubuntu:~$ cd Desktop/
hridesh@ubuntu:~/Desktop$ cd full\ netbeans\ 7.2\ for\ linux\ in\ .sh\ format/
hridesh@ubuntu:~/Desktop/full netbeans 7.2 for linux in .sh format$ chmod +x netbeans-7.1.2-ml-linux.sh
hridesh@ubuntu:~/Desktop/full netbeans 7.2 for linux in .sh format$ ./netbeans-7.1.2-ml-linux.sh
Configuring the installer...
Searching for JVM on the system...
Extracting installation data...
Installer file /home/hridesh/Desktop/full seems to be corrupted

Why does the message Installer file /home/hridesh/Desktop/full seems to be corrupted appear? Is this file actually corrupted or something else going wrong?

share|improve this question
1  
Did you solved your issue? –  pl1nk Jun 24 '12 at 14:02
    
yes i solved my issue.. –  Hirdesh Vishwdewa Apr 18 at 7:57

3 Answers 3

up vote 5 down vote accepted

The setup showed this error

Installer file /home/hridesh/Desktop/full seems to be corrupted

Since the full path being used is "home/hridesh/Desktop/full netbeans 7.2 for linux in .sh format" it would seem that the installer is having problem with such a complex folder name.

Renaming the folder "full netbeans 7.2 for linux in .sh format" to something simple like "netbeans_installer" should solve the problem the installer is reporting.

cd Desktop
mv full\ netbeans\ 7.2\ for\ linux\ in\ .sh\ format netbeans_installer
cd netbeans_installer
./netbeans-7.1.2-ml-linux.sh
share|improve this answer

Try

 sudo ./netbeans-7.1.2-ml-linux.sh
share|improve this answer
1  
If installing NetBeans globally for systemwide use (rather than for a single user), running the installer as root may help, but doing so is irrelevant to this problem. In this problem, the installer script runs but doesn't get far enough to install anything because it cannot access some file (perhaps a file it has just created, perhaps itself to read binary data out) in the directory where it resides. Furthermore, if installing NetBeans to be run and maintained by a single-user without affecting other users, the installer should not be run with sudo. –  Eliah Kagan Jun 14 '12 at 20:08
2  
-1 sudo is not the magical solution. Do not suggest it in cases like this, where the installation can be done in the user's home directory. –  Lekensteyn Jun 14 '12 at 20:16

Should be: sh netbeans-7.1.2-ml-linux.sh

share|improve this answer
1  
The script was able to start running the first time without being run that way -- ./ syntax was sufficient. This means that the script contains a hashbang line at the beginning, which means it's intended to be run with ./ syntax and doesn't need to be run by explicitly invoking sh. Furthermore, this is totally unrelated to the error message which was given once the script had already started running. –  Eliah Kagan Jun 14 '12 at 20:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.