Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Ubuntu 12.04 LTS on my Lenovo Y570, which already has Windows 7 on it.

In the installer, it says that no OS is currently installed on my computer, and it only gives me two options:

  1. Install Ubuntu and wipe the disk (which I'd rather not do)
  2. Something else.

I think what might be causing the problem is the fact that my Lenovo has a 64 GB SSD with Rapiddrive. I'm not sure about this. I've tried removing the dmraid metadata as suggested in an answer in here and also removing the dmraid (not sure what that means)is also suggested in the above article.

I'm completely new to Ubuntu, and (I apologize for this) ask that you keep your help as simple as possible. I have tried before to use the "Something new" option, but I only setup two partitions for Ubuntu (swap and one ext4 partition, with the ext4 being mounted at "/") and ended up having to restore my computer. I'd rather not go through that again unless I have extremely precise, step by step instructions (including how to setup the partitions, like what sizes and file systems.)


In response to BigGenius: I don't have any installation media, so no installation disc. I only have recovery media that I burned myself.

share|improve this question

You can try creating partition for Ubuntu manually and then using that partition for installing Ubuntu.

After installation if GRUB doesn't show Window 7 as option.

Try this:

  1. Boot in Window 7 installtion Disk.

  2. Choose Repair Use command prompt

  3. Use following commands:



share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.