Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Lenovo Thinkpad X60.

After upgrading to 12.04, first thing I did was get suspend to HDD back, because I don't use my battery a lot. So I did that.

After a while (about a week, I upgraded on release, not beta), maybe a week or so, I started getting black screens from time to time after waking it up from suspend to RAM. I never got that problem with suspend to HDD. As it only happens sometimes, I can't reproduce it. Sometimes it doesn't happen for a week (daily use, approx 2-6 wake-ups a day), then every single time.

The precise symptoms are as follows: normally I got a black screen with my cursor on it, which can be moved, no problems there. I can't interact with the system in any way except for turning it off on the 1/0 button. The weird thing is, the cursor seems to react to what I had opened when going into suspend to RAM, so for instance one day I had writer open and then my cursor was a "I" for most of the screen.

I only get this in 12.04, never had any problems with this in 9.04-11.10.

Any ideas?

share|improve this question
    
This isn't the first I've heard of this on 12.04, though I don't seem to be having a problem with it. The guys on the fullcirclemagazine podcast mentioned that they were having issues with suspend as well. I suppose that it's just a new bug introduced in 12.04 and hopefully a patch will go out soon, but I don't know of any way of applying a temporary fix. –  user70455 Jun 13 '12 at 21:35
1  
A lot of people get this bug, including myself. I switch to another tty session (ctrl - alt f1-12: f7 is xserver session) and fix from there. Are you familiar with bash and command line operations? –  Avery Laird Jun 13 '12 at 22:42
    
I have done some things in the past in the terminal, but I have no idea how to fix this issue from terminal. Maybe you could give me some instructions on how to find out what's wrong (maybe you know where the problem might be) and how to fix it temprarily and manually? That would be awesome! –  Naseschwarz Jun 14 '12 at 8:10
    
The same problem recently plagued me. But I don't have this problem until a few weeks after I installed ubuntu 12.04 (64bit). I have a Thinkpad T400. –  Yan Huang Oct 27 '12 at 16:41
add comment

3 Answers

I have the same problem as you and used to have a similar problem on previous versions (< 12.04). My solution used to be to go tty1 by pressing Ctrl+Alt+F1 and then killing the gnome-screensaver program. Things would go back to normal.

This has not worked for me in 12.04, but maybe it might work for you. In 12.04, all I can do is killall -u myusername to close my session and then I have to log back in just to avoid having to reboot.

share|improve this answer
2  
I tried the following and it worked fine two times so far: I switched with ctrl + alt + f1 and typed "sudo restart lightdm". This will get you back to your graphical desktop, but your programs won't be open anymore. It's been suggested that you log off from ctrl+alt+f1 once you got back to your GUI. Otherwise your next wake-up will have the same problem again. I got this from a fellow Thinkpad user, so I'm not shure if it works for everyone else. There seems to be a problem with energy management in Thinkpad and ubuntu or gnome... I don't know the details. –  Naseschwarz Jun 17 '12 at 7:19
    
killall -u myusername works, but i'm not sure its any better than hard restart... –  Jonathan Day Oct 10 '12 at 22:09
add comment

Better still:

Before closing the lid initiate the suspend via the GUI. (The option right above shutdown)

Wait for the laptop to suspend then close the lid. Once you open the lid you can input the password and return to your work without having to restart anything.

I tried this on a ThinkPad Edge.

Can anyone verify that this works for other models/brands?

share|improve this answer
add comment

This seems to primarily be a Gnome 3.6.1 bug.

After changing to TTY (Ctrl-Alt-F1) and logging in, set your DISPLAY variable, then send the command to gnome-screensaver to disable the screensaver:

$ export DISPLAY=:0.0
$ gnome-screensaver-command -d

You can then switch back to Gnome with Ctrl+Alt+F7.

This is already fixed in Gnome 3.6.2.

Solution source, but more vague

Multiple reports of this bug

share|improve this answer
add comment

protected by Community Oct 27 '12 at 19:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.