Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu (64-bit version) on a vm through VirtualBox on a Windows 7 64-bit host, but I fear that I've done something wrong. First, when I restart my computer, it just goes straight to Windows 7, as normal. Is there a separate step to have a selection menu at start-up or does this not apply for VirtualBox runs of Ubuntu?

Then, when I go to "Devices-->Install Guest Additions" within Ubuntu (running it by simply starting VB and clicking start on VB GUI for Ubuntu), I get the following error message:

Unable to mount the CD/DVD image C:\Program Files\Oracle\VirtualBox\VBoxGuestAdditions.iso on the machine Ubuntu Desktop 12.04 64-bit. Would you like to force mounting of this medium? Could not mount the media/drive 'C:\Program Files\Oracle\VirtualBox/VBoxGuestAdditions.iso' (VERR_PDM_MEDIA_LOCKED).

And I get a choice to "Force Unmount" the mounted ISO file within (which is indeed the VBoxGuestAdditions).

Also, when I click on the CD icon on the bottom right of the Ubuntu window so that I can "remove disk from virtual disk", I get a similar error message, except this time it says that it cannot unmount:

Unable to unmount the CD/DVD image C:\Program Files\Oracle\VirtualBox\VBoxGuestAdditions.iso from the machine Ubuntu Desktop 12.04 64-bit. Would you like to force unmounting of this medium? Could not unmount the currently mounted media/drive (VERR_PDM_MEDIA_LOCKED).

But when I go to the VB GUI and select "Settings" and go to Storage, I guess I can unmount from there because I get no error message. If I unmount there and then go back into Ubuntu, the virtual CD is unmounted. Any help would be awesome!

share|improve this question
    
Please remember to accept/upvote the best answer to your question (tick/check mark on the left). This way, the question is marked as "answered" and future readers can refer to it knowing the solution works. Thank you...:) –  izx Jun 24 '12 at 7:35

1 Answer 1

up vote 8 down vote accepted

First, when I restart my computer, it just goes straight to Windows 7, as normal. Is there a separate step to have a selection menu at start-up or does this not apply for VirtualBox runs of Ubuntu?

That's normal. A virtual machine will not come up as an option in the physical host's boot menu. You must start the host OS and the virtual machine manager (hypervisor) before that can happen.

And I get a choice to "Force Unmount" the mounted ISO file within (which is indeed the VBoxGuestAdditions).

  • Try ejecting the virtual drive from within the OS first:

enter image description here

  • You can also use sudo unmount /media/title-of-cd from the terminal.
  • Then try unmounting from VirtualBox. Sometimes that may still give you the warning, but just override it so long as you ejected from Ubuntu first.
share|improve this answer
    
I was successful at unmounting the VBoxGuestAdditions virtual disc within the home menu. I then mounted it again and re-installed the guest additions. And thanks for the answer! But I'm unsure regarding how to make Ubuntu come up as a selection at start-up: what do you mean by starting the OS and virtual machine manager? I thought I had done those things already. –  Jay Jun 13 '12 at 19:12
1  
The machine installed in VB will only start when VB run. It will not run as an alternative OS to the host OS. To do that, you have to install that in your machine, not in VB. VB is like any program, like your web browser or word processor. You have to run VB to be able to run your virtual machines in VB. –  Anders Jun 14 '12 at 22:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.