Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Alright, so here's the situation:

I am using an ASUS UL80VT with two graphics cards: Integrated intel graphics and NVIDIA G210M

I was running an Ubuntu 12.04 - Windows 7 dual boot (on separate partitions).The machine worked perfectly (including the display drivers) without me needing to install anything special or change any settings. However, my hard drive was corrupted and I lost all my data yesterday, so after it was replaced, I installed Ubuntu 12.04 64x again after installing Windows 7.

I booted up Ubuntu after installation, and noticed it was by default using Unity 2D... Gnome 3.4 wasn't working properly either, so I guessed that the NVIDIA G210M driver wasn't installed/working and the OS was instead using the integrated graphics. I checked the "Additional Drivers" thing, but there were no proprietary drivers listed there, so I went to the NVIDIA website, downloaded the driver directly and installed it. I restarted, but there was no change.

After this, I read somewhere that I should change my SATA in the BIOS to "Compatible" rather than "Enhanced". This worked fine and fixed the problem (both Unity and Gnome were working perfectly) but then when I tried booting up Windows 7, I recieved the BSOD. So I changed it back to Enhanced, and once again, the NVIDIA 210M graphics isn't working on Ubuntu, but on Windows 7 it is. I do not want to keep changing from Enhanced to Compatible every time I reboot to Ubuntu and neither do I want to simply just use one OS.

Note that NVIDIA 210M and integrated graphics work perfectly on Windows 7. Also, I don't care about switching between them, I just want to be able to use the NVIDIA one.

What can I do so that both Windows 7 and Ubuntu work and NVIDIA G210M works on Ubuntu?

share|improve this question
    
does the driver supported by ubuntu software center has the same issue? As per your words, b4 HDD crash, you seem to not have this issue. After new HDD and new ubuntu and Nvidia driver you are having this issue. –  zenwalker Jun 13 '12 at 17:52
add comment

3 Answers 3

To be honest, I think your problem is just related with your configurations. As far as I know, if you installed W7 with one HDD mode in the BIOS, you cannot change it back to the other mode, b/c Windows won't recognize those changes on the SATA controller.

Why I said that? Because I had a similar problem with an Acer laptop.

Probably there is another option, but the way I solve it was by re-installing everything again, but this time be sure the SATA mode is the "compatible" instead of "enhanced". Install w7 again and it should work properly under both, W7 and Ubuntu.

I know it is a brute solution, but it was the only that really works for me.

share|improve this answer
    
Is this the only way to fix this? It would be difficult for me to reinstall windows since I currently don't have the installation CD (and do not want to torrent the iso). Anyways, thank you for the input and I will try this as a last resort. –  Noob. Jun 13 '12 at 18:52
add comment

There is a setting in BIOS setup for VGA Controller selection in most BIOS. Set that to 'Others' and you should get the graphics card.

share|improve this answer
add comment

Open up your xorg.conf file from /usr/share/x11/xorg.conf.d/

Note: I can't remember if its this directory or this one... /etc/x11/xorg.conf.d/

Maybe someone else remembers? I'm not at my PC now, and 13.04 doesn't create an xorg.conf file anymore so I've never actually used the file, just studied about it.

Look for the line about your display device, and if you can't find one write your own. Make it match the exact device description, which can be found by opening the terminal and typing

lspci

to display all detected PCI hardware. If its not listed then you have a "Linux doesn't detect my video card" problem.

If this doesn't work try entering a tty with Ctrl+alt+F6 and enter the command to reinstall the entire Ubuntu desktop including unity, xorg, etc.

sudo apt-get install --reinstall ubuntu-desktop

Good luck.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.