Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

MySQL workbench was working fine till today. I installed the regular updates and now its just doesnt starts. When started its just shows the 'opening screen' and nothing happens.

I tried re-installing it from synaptic but no luck. I use it all the time and now suffering a lot. Any help will be appreciated.

When run from terminal with: mysql-workbench --log-level=debug3 --verbose

It gives a long log. Please see at: http://pastebin.com/Z2t8pdZF

I see these error in the log but don't know what they mean and how it stopped working automatically,

/home/atul/.mysql/workbench/wb_state.xml:1: parser error : Document is empty

^ /home/atul/.mysql/workbench/wb_state.xml:1: parser error : Start tag expected, '<' not found

^ /home/atul/.mysql/workbench/user_starters.xml:1: parser error : Document is empty

^ /home/atul/.mysql/workbench/user_starters.xml:1: parser error : Start tag expected, '<' not found

^ /home/atul/.mysql/workbench/starters_settings.xml:1: parser error : Document is empty

^ /home/atul/.mysql/workbench/starters_settings.xml:1: parser error : Start tag expected, '<' not found

Atul

share|improve this question

5 Answers 5

This is the solution that resolved my problem:

I (kind of) fixed mine by going to /home/username/mysql/ and renaming (or deleting) the workbench folder.

It's ok and now my Worbench runs very well!

share|improve this answer
up vote 1 down vote accepted

Canonical and God knows what went wrong. But here is a fix:

Download:

For 64 bit systems: http://launchpadlibrarian.net/56565535/libzip1_0.9-3ubuntu0.1_amd64.deb

For 32 bit systems: http://launchpadlibrarian.net/56565266/libzip1_0.9-3ubuntu0.1_i386.deb

Once downloaded, double click to install.

Now Download the latest version of My SQL workbench, Its for 11.10 but will work on 12.04. Make sure you download the version (32bit or 64 bit) suitable to you: http://www.mysql.com/downloads/workbench/#downloads

Once downloaded, double click on it to install.

And you are done.

Atul Kakrana

share|improve this answer

I (kind of) fixed mine by going to /home/<your username>/.mysql/ and renaming (or deleting) the workbench folder. All of your connections need to be re-entered, but it's worth it to get your database program back up and running. The only reason I'm saying this is, because this was the only way I could get mine to work, no other solutions on the internet worked for me. I'm using Ubuntu 12.04, but this should work on any other version of Ubuntu as well.

share|improve this answer

Instead of renaming (or deleting) the workbench folder.You just have to delete wb_options.xml inside /home/<your username>/.mysql/workbench/.

This fixes the issue and moreover all your data residing in your database is still there.

This is definitely a better option than re-installing mysql-workbench again.

share|improve this answer

In ubuntu 13.04 I had the same problem to fix it

I ran

sudo apt-get remove mysql-workbench

sudo apt-get remove mysql-woorkbench-data

later removed workbench directory in

/home/username/.mysql

and reinstalled mysql-workbench it started working

share|improve this answer
    
this also worked for 12.04 –  themhz Aug 14 at 13:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.