Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm very used to use edge bindings in my workflow, but since I've updated to 12.04 Unity forget my edge bindings settings on every new session.

Why it is appening and how to fix it?

share|improve this question
    
Possible duplicate? askubuntu.com/questions/130732/… –  reverendj1 Jun 13 '12 at 14:09

2 Answers 2

up vote 0 down vote accepted

I think that the real problem is not that "Unity dosn't remeber the bindings" but rather that something is blocking the edge pixels from being reached. If you do anything that forces compiz to refresh the settings (enable or disable widget layer for example), the edges are working again. I think it's like that compiz is running but it is behind unity not on top (like an inactiv window i supose). This explains the working solution for startup programs, because its runs again compiz and forces that refresh. I haven't thought so, i all i did to fix the problem was a restart with alt+f2 and runing compiz --replace command as soon as the desktop started.

In conclusion, something is blocking compiz edges, and stays on top, till you resfresh it in anyway.

I like to believe it will be fixed, cause the edges is THE most amazing thing for ubuntu in general.

share|improve this answer

Okay here it is.

  1. "Why is it happening?"
  2. "How to fix it?"

    • Here I'll share two answer, that solves my edge binding problem for my 12.04.
      But, it might not work on other computer.

    First

    • One problem that I found is, python-compizconfig, which is Compizconfig bindings for python is not included with compizconfig-setting-manager.
      • So you have to install it manually, or, it will be automatically installed with Ubuntu Tweak (That's why I recommend you Ubuntu Tweak).
      • With Ubuntu Tweak, you can find the edge binding settings under Tweak > Workspace.

    Workspace

    Second

    • Another one is taken from @sachinr's answer.

      Add Compiz to the startup applications.

      Name    : Compiz
      Command : bash -c "sleep 3; compiz --replace"
      

Now with those, my edge binding settings "remembered" whenever I start a new session.

share|improve this answer
    
Thanks, I know ubuntu tweak tool, that's not a solution and an answer to why. –  neonboy Jun 13 '12 at 21:52
    
Updated my answer. Please, think for it before you say that it is not a solution. I was just sharing my way to solve it easily. –  Drie Jun 14 '12 at 6:15
    
Thanks, I know ubuntu tweak tool, that's not a solution since it hasn't got the functionalities I require, which are present in compiz instead, for example I use edge bindings to drag & drop text and files from one workspace to another, or to group windows of the same application in scale plugin, theese are compiz feature, I'n not interested in ubuntu tweak tool, I use it but for others task. And sachinir's answer doesn't work for me, thanks anyway. –  neonboy Jun 14 '12 at 11:47
    
Oh I get it now. You could have mentioned those before. Well since the basic bindings are working here, I tried to change the bindings to some advanced ones (like group windows of the same application) from ccsm and rebooted my system, fortunately the settings were remembered. I still can't find what the exact problem here, though. –  Drie Jun 14 '12 at 12:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.