Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

when booting i have the option to select Ubuntu or windows but when selecting ubuntu instead of going to Ubuntu boot screen it goes to the Ubuntu boot menu where you can select, kernel or another version of Ubuntu. why is this? can this be fixed by wubi?

share|improve this question
    
To get a more clear idea of your configuration could you run boot info script as explained here: ubuntuforums.org/showthread.php?t=1291280 and post the RESULTS.txt? (if Ubuntuforums is still down when you read this the script's actual website is sourceforge.net/projects/bootinfoscript ). –  Jordan Uggla Jan 29 '11 at 22:23
add comment

2 Answers 2

This is not a problem of wubi. The grub menu is poped out, maybe because u installed newer kernel version. Grub is always there, it just didn't show up when u just have one kernel version. If you wanna disable it, u need modify the grub2 config file, under dir /etc/grub.d

Grub2 manual page

share|improve this answer
    
To edit the correct files, please look at help.ubuntu.com/community/Grub2#/etc/default/grub%20%28file%29 first. –  charlie-tca Nov 28 '10 at 0:00
add comment

If you only have Windows and a single Ubuntu install, installed via Wubi, then you should be able to eliminate the extra menu by adding GRUB_DISABLE_OS_PROBER=true to /etc/default/grub then running sudo update-grub.

Ubuntu by default hides the GRUB menu when Ubuntu is the only OS installed, and shows it when additional OSs (like Windows) are detected so that you can choose between OSs at the GRUB boot menu. Because you are using Wubi, you can select Windows from the Windows bootloader, so you don't need to be given the option again at the GRUB menu. By using GRUB_DISABLE_OS_PROBER=true you disable the automatic detection of other OSs by grub, which both removes the Windows option in the GRUB menu and hides the menu.

If you actually have more than two OSs, for instance one regular install of Ubuntu in addition to Windows and the Wubi install then you might not want to use GRUB_DISABLE_OS_PROBER=true. That's why I asked for boot info script output to be sure that I understand your exact situation.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.