Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just recently switched from Windows 7 over to Ubuntu 12.04 and have been experiencing some issues connecting to my home's wireless network.

The only way I can get it to connect to the network is by disabling IPv4 and IPv6 settings. Even then while it says its connected to the network (3 bars), I'm unable to access the Internet.

It connected for a little while after I first installed Ubuntu, but after the first reboot I haven't been able to access the web at all. I have very basic knowledge when it comes to computers and barely any when dealing with Ubuntu and Linux.

I'm very happy with Ubuntu apart from this one issue, as before my computer was overheating and crashing, I've yet to experience any of those problems since installing Ubuntu. The information I can give may be very limited since I'm having to use my cell phone to figure out the solution to this. Any help would be greatly appreciated. Thanks in advance!

share|improve this question
    
You can accept your own answer--that is common practice here. –  hexafraction Jun 16 '12 at 15:54
add comment

1 Answer

I got it figured out. I disabled IPv4 and got it connected to the device, then found out the IP, subnet, gateway, and DNS in terminal using ifconfig and route -n then put them in manually and now everything works fine. Can't believe it took me several days to find out something so simple! Anyway, I look forward to using and learning about Ubuntu for years to come. So glad I don't have to deal with all the hassle that comes with Windows anymore. Hope everyone has a wonderful day!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.