Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have used gtk-recordMyDesktop to make a video as an OGV file using the default settings. I need to do 3 things:

  1. How can I reduce the screen resolution (height and width) so that it can fit into a smaller video size on my website?

  2. How can I pull out like every third frame so that the file size is not so large, yet not mess up the sound?

  3. Not all Windows IE users can view OGV files. How can I convert to FLV (or, as a fallback, MP4) so that I can share on my blog?

share|improve this question
@Samik, please make that an answer, it's a great comment! – izx Jun 13 '12 at 9:18
@Samik, of course! I recommend adding a comment re the 2nd q that for modern codecs such as OGV/FLV/MP4, adjusting the bitrate is a better way to control the final file size rather than decimation (reducing frame rate by dropping frames) – izx Jun 13 '12 at 9:22
I'm having a problem choosing which is the best answer the one from Samik or Mitch. They both sound so good. Right now I'm running ffmpeg to see the outcome. – Volomike Jun 13 '12 at 9:35
up vote 3 down vote accepted

You can resize and convert with ffmpeg using ffmpeg -i input.ogv -s widthxheight -sameq output.flv.
You can also change the video bit rate with -b:v bitarate and control the frame rate with -r framerate to reduce the size of outcome. As izx has mentioned the bit rate option is recommended over changing frame rate or dropping frames.

share|improve this answer
Where can I find documentation on the bitrate in human-readable terms? I'm not certain what value to put there. – Volomike Jun 13 '12 at 9:39
@Volomike You can use human-readable format like for 64Kb/s you should use -b:v 64k. You can consult to ffmpeg documentation and also the man page (man ffmpeg) – Samik Jun 13 '12 at 9:42
I get "unrecognized option '-b:v'", unfortunately. – Volomike Jun 13 '12 at 9:45
@Volomike Sorry for that inconvenience, did you get over it? It can happen if ffmpeg version is very old. You can use -b instead. Newer versions allows you to separately change video and audio bit rate with -b set default to audio. – Samik Jun 13 '12 at 9:56

You can use Avidemux

Avidemux is a free video editor used mainly for simple cutting, filtering and encoding tasks. It is often dubbed as the VirtualDub for Linux as it can do many things that VirtualDub can do. It supports many files types, including avi, DVD compatible mpeg files, mp4, asf and even the not-so-common ogm and matroska format.

Some of the useful features of Avidemux include a simple WYSIWYG interface, easy conversion from one format to another, plenty of filtering effects and a built-in subtitles processing capabilities.

Source: USC

You can also use Pitivi Video Editor

Adding a Screencast / Video Clip into Pitivi

In order to add video clips into your Pitivi project, simply click on IMPORT CLIPS and select the appropriate video file. Note: video file clips can also relate to screen-casts created with gtk-recordmydesktop. The Pitivi video editor accepts many different video clip file formats.

Examples of Accepted File Formats:

  • MPEG
  • AVI
  • MP4
  • OGV (Ogg Theora Vorbis)


To add the video clip into the project area, simply click and drag the object into the area below the Timeline Ruler. Quoted from this site

After you import the file, add it to the timeline, and do your editing, click on the render button, and it will allow you to save the file as .flv. enter image description here

share|improve this answer
This didn't work too well. It wouldn't let me open an OGV file. – Volomike Jun 13 '12 at 9:50
Pitivi has no export option that I could see. – Volomike Jun 13 '12 at 10:00
You have to import the file to edit it – Mitch Jun 13 '12 at 10:08
I did import it into Pitivi, but unfortunately there was no option to export in a different format. Note I'm running Ubuntu 10.04 LTS still. – Volomike Jun 13 '12 at 10:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.