Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Generally I use this command to create a local Socks proxy via SSH Tunneling

ssh -ND 7777 -i google.pem ubuntu@107.20.x.x

Then i configure my applications to use Socks proxy on localhost (i.e. 127.0.0.1 )

And it works as expected.

I recently came across a Gnome Application, Gnome SSH Tunnel Manager, also available in the repositories as gstm. GSTM has more features which I need, like Auto Restart and Auto connect on Start up

I am unable to use it as per my requirement.

Here's my GSTM setup:

enter image description here

And the ports on the server I'm trying to connect to:

enter image description here

share|improve this question
1  
Ehmm where is the question? Could you provide more info? –  pl1nk Jun 13 '12 at 8:25
    
Hey, thanks. I edited the question –  BigSack Jun 13 '12 at 8:30

1 Answer 1

up vote 4 down vote accepted

You're setting up the redirection incorrectly. To get the SOCKS proxy you need to set up a dynamic redirect -- just one different click (see screenshot). You just need to set the port you want to use on localhost (here, 8888), and leave the remaining as is (n/a).

enter image description here

share|improve this answer
    
Thanks, Worked as charm! –  BigSack Jun 13 '12 at 8:34
    
I was just going to do it, system pulled me back. I has some time limit. –  BigSack Jun 13 '12 at 8:44
    
No, ath9k is still pending. I managed to change reg domain.But it reads it from EPPROM and therefore i can't override it. I need to patch drivers to override that. –  BigSack Jun 13 '12 at 8:47
    
Thanks. Re ath9k I think you need to rebuild the crda package after modifying the source. I will try to answer that soon. –  izx Jun 13 '12 at 8:52
    
Do you also own same card? I tried to do CRDA, but it is also not working for me or may be i just did it wrong. –  BigSack Jun 13 '12 at 9:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.