Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ppa:cr3/ppa in my sources list. It upgrades my checkbox, checkbox-gtk, and checkbox-qt packages to version 0.14~ppa6.12.04. And now I have problems with updating my system, and sometimes critical system errors.

I tried to use ppa-purge to downgrade them - it didn't work. I tried to delete them from synaptic - it wants to delete ubuntu-desktop with them.

When I try to update system I'm getting an error:

 checkbox
 checkbox-gtk
 checkbox-qt
E: Sub-process /usr/bin/dpkg returned an error code (1)

How can I solve this problem?

share|improve this question
    
Deleting ubuntu-desktop shouldn't be a problem. We can reinstall them later on.. It's a meta package at best. –  jokerdino Jun 13 '12 at 7:47
3  
I recommend adding the output of ppa-purge to your question. (You can run it again to get the error output, if you no longer have it up.) –  Eliah Kagan Jun 13 '12 at 7:51
    
I can't do it... to much of characters.... –  Simplehuman Jun 15 '12 at 10:00
add comment

1 Answer 1

You should be able to force version for those packages, setting them to use the official repository one doing a click on each of them in synaptic, then package menu -> force version...

Once you set them back, feel free to remove third party repos and upgrade safely.

share|improve this answer
    
Thank you for your answer. For checkbox-gtk and checkbox-qt it works. But checkbox is remaining 0.14~ppa6 :( I am getting the same error message. –  Simplehuman Jun 15 '12 at 9:50
    
checkbox version in official 12.04 repos is 0.13.7. Try forcing it manually with sudo apt-get install checkbox=0.13.7 –  jasmines Jun 15 '12 at 9:58
    
I have purged all of them with ubuntu-desktop package ... And just install them again . Everything is working, thank you. –  Simplehuman Jun 15 '12 at 10:26
    
You're welcome! Don't forget to accept the answer :) –  jasmines Jun 15 '12 at 11:06
    
HA! he forgot to accept the answer –  blade19899 Nov 29 '13 at 15:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.