Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot find the settings anywhere do I have to set it through terminal through gconftools or is there some GUI present for it?

share|improve this question

5 Answers 5

up vote 47 down vote accepted

System-wide proxies in Ubuntu Studio, Xubuntu and XFCE must be set via environment variables

Ubuntu Studio, like Xubuntu, uses the XFCE desktop environment which does not contain a graphical settings tool to set systemwide proxies (unlike the default Ubuntu desktop environment, Unity).

1. Set up the proxy/proxies for most programs

  • Open the /etc/environment file with gksudo leafpad (or your favorite editor). This file stores the system-wide variables initialized upon boot.
  • Add the following lines, modifying appropriately. You must duplicate in both upper-case and lower-case because (unfortunately) some programs only look for one or the other:

    http_proxy=http://myproxy.server.com:8080/
    https_proxy=http://myproxy.server.com:8080/
    ftp_proxy=http://myproxy.server.com:8080/
    no_proxy="localhost,127.0.0.1,localaddress,.localdomain.com"
    HTTP_PROXY=http://myproxy.server.com:8080/
    HTTPS_PROXY=http://myproxy.server.com:8080/
    FTP_PROXY=http://myproxy.server.com:8080/
    NO_PROXY="localhost,127.0.0.1,localaddress,.localdomain.com"
    

2. Then set up proxies for GTK3 programs such as Rhythmbox:

Some newer GTK3 programs such as Rhythmbox ignore the environment variables set above, and rely on Gnome settings instead. To make sure they are covered, open a terminal and paste the below line-by-line, modifying as appropriate:

gsettings set org.gnome.system.proxy mode 'manual' 
gsettings set org.gnome.system.proxy.http host 'myproxy.server.com'
gsettings set org.gnome.system.proxy.http port 8080

3. Finally, set up the proxies for apt-get and Update Manager

  • These programs will not obey the environment variables either. Create a file called 95proxies in /etc/apt/apt.conf.d/, and include the following:

    Acquire::http::proxy "http://myproxy.server.com:8080/";
    Acquire::ftp::proxy "ftp://myproxy.server.com:8080/";
    Acquire::https::proxy "https://myproxy.server.com:8080/";
    

Finally, logout and reboot to make sure the changes take effect.


Sources: 1, 2, 3. See 1 in particular for additional help, including a script to quickly turn on/off the proxies.

share|improve this answer
    
+1 ;-) It helped. Thanks. –  Majid Fouladpour Jun 28 '12 at 7:47
1  
Related: superuser.com/questions/357688/… –  Grzegorz Oledzki Nov 12 '12 at 8:09
    
    
only reboot and ready for xfce!. Thanks. –  RckLN Aug 9 '13 at 19:29
3  
The above worked for me. But when I take my laptop home from work, where there is no proxy - I can't connect to the internet. Is there a short-cut way to disable the proxy again when I get home without going to the extremes of rotating config files and rebooting? It would be a nice addition to the answer. –  TenLeftFingers Mar 7 at 12:58

there is a graphical tool called UbProxy, that sets the whole systema proxy, via a graphical interface (GUI). The only problem for me, was I have to log out my user and log in again to load the config. Is very simple to use. https://code.google.com/p/ubproxy/

share|improve this answer
    
looks promising. –  Dee May 23 '13 at 7:20

I have some functions for dealing with that. Call them like this:

myProxyOn

https://gist.github.com/fernando-basso/6352040

#!/usr/bin/env bash

# gsettings list-recursively org.gnome.system.proxy

# Change de ip address and port number accordingly.
function myProxyOn() {
    gsettings set org.gnome.system.proxy mode 'manual' # ' manual / nome / automatic '
    gsettings set org.gnome.system.proxy.http host '10.0.0.1'
    gsettings set org.gnome.system.proxy.http port 8080
    gsettings set org.gnome.system.proxy.https host '10.0.0.1'
    gsettings set org.gnome.system.proxy.https port 8080
    gsettings set org.gnome.system.proxy.ftp host '10.0.0.1'
    gsettings set org.gnome.system.proxy.ftp port 8080

    echo "Configuração do 'System Proxy' settada para 'manual', com host 10.0.0.1, port 8080."
}

function myProxyOff() {
    gsettings set org.gnome.system.proxy mode 'none' # ' manual / nome / automatic '
    echo "Proxy cofigurado para 'none'."
}

function proxyOn() { # {{{
    #echo -n 'Username: '
    #read -e username
    #echo -n 'Password: '
    #read -es password
    #echo ''
    echo 'Setting variable "http_proxy"...'
    #export http_proxy="http://$username:$[email protected]:8080/"
    export http_proxy="http://10.0.0.1:8080/"
    echo 'Setting variable "https_proxy..."'
    export https_proxy="https://10.0.0.1:8080/"
    echo 'Setting variable "ftp_proxy"...'
    #export ftp_proxy="http://$username:$[email protected]:8080/"
    export ftp_proxy="ftp://10.0.0.1:8080/"
    echo 'Done!'
}

function proxyOff() {
    unset HTTP_PROXY
    unset http_proxy
    unset FTP_proxy
    unset ftp_proxy
    echo -e "\nProxy environment variables removed!"
}
share|improve this answer
1  
that is an awful suggestion to store the password in a text file –  BЈовић Mar 31 at 11:56
    
@BЈовић: You are right. In my case, it is the public uni proxy password, so, I guess it doesn't matter. –  Fernando Basso Mar 31 at 15:50

It is not necessary to restart whole system for apt-get tweak via proxy95 file in /etc/apt/apt.conf.d

  • It just works immediately after file is written and
  • it is gone immediately after the file disappears.

Consider script to enable and disable file by renaming it to *.bak for quick switching the proxy if necessary.

share|improve this answer

Go to Dash Home type System Settings, click system settings then network.Proxy settings will be visible to you. Click system wide. It may work as in system proxy settings.

share|improve this answer
1  
Studio uses xfce not ubuntu. –  Elfy Jun 13 '12 at 12:44
1  
Try superuser.com/questions/357688/… –  Elfy Jun 13 '12 at 12:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.