Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install php 5.3.9 in ubuntu 12.04 via apt-get.

apt-cache show php5-fpm

only lists 5.3.10-1ubuntu3.1 and 5.3.10-1ubuntu3. There is a critical bug in 5.3.10 ( https://bugs.php.net/bug.php?id=61045&edit=1 ) that I am trying to avoid.

Is there a repository that will let me install php 5.3.9 in ubuntu 12.04 LTS?

share|improve this question
add comment

1 Answer 1

As 5.3.10 is newer than 5.3.9, even if there were a repository with 5.3.9, the 5.3.10 package would still get installed. It seems from the bug as if the bug is fixed in 5.3.12, and should apply to 5.3.10, so perhaps pushing for the patch to get included in an SRU, and helping to get that done, would be a better solution. It would then fix it for everyone, and not need a PPA for people to get it.

You can see the procedure for getting an SRU, here: https://wiki.ubuntu.com/StableReleaseUpdates

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.