Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The pactl module module-loopback is loaded every time I turn on my computer. I'm not sure why, but I always have to use pactl unload-module 20 (for some reason the module is always id 20).

Is there somewhere I accidentally turned this on or some bash login script I accidentally put this in? Where can I look to resolve this?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Some places come to mind where you may want to look for loading of the loopback-device:

  • Have a look at your /etc/pulse/default.pa or in case you have defined it for a local user in ~/.pulse/default.pa to comment out this line if present like this:

    # load-module module-loopback <optional parameters>
    
  • Check with paprefs (if installed) whether we have ticked the option "Loopback audio to local speakers" in the Mulicast/RTP settings tab.

  • You may have made a setting like "Monitor of..." in pavucontrol.

  • There may be or may have been another application installed that needs the loopback module to operate (search for any possible application that may come into consideration).

share|improve this answer
    
Thanks, it was in /etc/pulse/default.pa . I must have put it in there and forgotten about it. –  you786 Jun 13 '12 at 15:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.