Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I left my computer downloading all the night and I did download 35 GB of movies (legal ...). I restarted the computed in the morning then I booted in my encrypted Windows partition for my work.

I have left my computer downloading 35GB of files and when I restarted in the morning, I booted Windows. When I tried to access Ubuntu, it failed to boot and in low-graphic mode told me that it won't boot because the partition is full. I tried rescue and it reported 0 MB free.

I also cannot delete files with sudo rm as all are impossible due to a read-only file system. I can mount it in Windows but there is a "write protection" there, also.

Should I try a live USB?

share|improve this question
3  
First step: do not panic. Panic leads to trouble and shortens life. –  Rafał Cieślak Jun 12 '12 at 22:06
    
@rafalcieslak thanks i am not panicking i am pissed off! You dont have a solution? –  mike Jun 12 '12 at 22:09
    
@mike Let's not get angry. The main way to solve a problem is to step back and look at the big picture. –  hexafraction Jun 12 '12 at 23:12
add comment

3 Answers

When you boot into rescue mode, the filesystem is initially mounted read-only. To mount it read/write, run:

mount -o remount,rw /

Then you should be able to delete some files to free up some space.

share|improve this answer
add comment

Try booting with a live cd (or usb). You should be able to access your file system and free up some space so that it will boot.

I'm pretty sure Windows can only read EXT3/4 filesystems which is why it said that it is write protected.

share|improve this answer
4  
Without special third-party drivers, Windows cannot access ext2, ext3, and ext4 filesystems at all. –  Eliah Kagan Jun 12 '12 at 23:12
add comment

Try entering recovery mode(or even a terminal in a regular boot). Then, execute each of these commands(fill in the correct partition for /dev/sd??, as I am unsure of what it is on your system.

sudo mkdir /mount/recover

sudo mount -t ext4 /dev/sd?? /mount/recover

cd /mount/recover

Now, you can try deleting files using a command-line or if you are able to get a GUI running, delete/interact with them there.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.