Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Since I installed 12.04 I have problems with updating. I get lots of messages of the following kind:

W:Failed to fetch  404  Not Found [IP: 80]

Somebody has an idea of what's wrong?

share|improve this question
It looks like that archive might not be responding, or its searching for something on that mirror that doesnt exist. A 404 error usually means that that mirror doesnt have a package list for you... –  Thomas W. Jun 12 '12 at 19:53

1 Answer 1

You can select an alternate mirror from the software center, under the "download from" menu.

enter image description here

share|improve this answer
Thanks, it worked. I had already tried changing from the Main Server to the German Server, but had the same bad result. After your post I changed to the Luxembourg Server and it worked... –  Antonio Jun 13 '12 at 14:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.