Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having the same problem as mentioned here on two computers (one runs 12.04, while the other runs 11.10), but the solution provided does not work for me.

When I do update and upgrade through the terminal, I get the following

Preconfiguring packages ...
Selecting previously unselected package zramswap-enabler.
(Reading database ... 216245 files and directories currently installed.)
Preparing to replace zramswap-enabler 0.2.1-0~19~precise1 (using .../zramswap-enabler_0.2.1-0~21~precise1_all.deb) ...

and then it simply stays like that.

When I try to update using the Update Manager, I get a warning that not updates can be insalled and I need to do a partial upgrade. Again, when I try to do the partial upgrade, the proces is simply stuck at the zramswap-enabler update.

When I try to do as the solution mentioned above said, I get this:

sudo dpkg --remove --force-remove-reinstreq zramswap-enabler
dpkg: warning: overriding problem because --force enabled:
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
(Reading database ... 50%
(Reading database ... 216244 files and directories currently installed.)
Removing zramswap-enabler ...

and just like when I try to update, it simply stays stuck there.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

When the process stalls at "Preparing to replace zramswap-enabler", open another terminal and try running "sudo start zramswap".

share|improve this answer
    
Worked like a charm for the pc running 12.04. I'll try on the other one later. thanks for the help. –  Ceipheed Jun 13 '12 at 18:10
    
Worked on 11.10 as well. –  Ceipheed Jun 13 '12 at 22:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.