Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having problems restarting or turning of ubuntu 10.10 on a samsung r560. I had no problems with previous ubuntu versions.

When turning off, ubuntu stays forever in the purple screen with 4 dots. When restartig, I get

init: Disconnectded from system bus
init: dbus main process (752) killed by TERM signal

nm-dispatcher.action: Cought signal 15, shutting down...
modem-manager: Cought signal 15, shutting down...

The laptop does not shut down after this.

share|improve this question
    
tried sudo reboot, did not help. this time I got stuck on the back screen that says ubuntu 10.10 and displays .... under it. –  varsketiz Nov 26 '10 at 17:06
    
Have you tried sudo halt ? –  karthick87 Nov 26 '10 at 18:30
1  
Do you have any mapped network drives in your /etc/fstab? If so, and you connect to those via WIFI, this is a known bug (but usually also results in a CIFS error, which I don't see in your output). –  Scaine Nov 26 '10 at 20:12
    
I deleted all mapped drives from /etc/fstab but its still the same. I connect to internet via wifi, but I do not connect to any devices this way. I usually have an external hdd attached (usb) + mouse (usb), but I tried without it, same problem. Also, the output is not always like this. Its different every time. One thing I noticed is that if I press "escape", I get to black screen with blinking _ at the top. if I press escape one more time I get to the purple ubuntu screen again. –  varsketiz Jan 16 '11 at 21:30

3 Answers 3

Do you have an external storage device installed on the computer? Try removing first before shutting down.

I found this http://ubuntuforums.org/showthread.php?t=1603642 Not sure if it applies to your situation. This one is a wireless issue.

share|improve this answer
    
Thanks you your attempts, but these suggestions did not drive me to the solution to this problem. Is there any log (or can I set up one) for what goes on on this shutdown command? –  varsketiz Jan 16 '11 at 20:58

In terminal type sudo reboot or sudo halt to halt your system

For shutting down instantly,

sudo shutdown -P now or sudo poweroff or sudo su && init 0

Also See this thread

share|improve this answer
up vote 1 down vote accepted

my issue was that rabbit-mq server was stopping me from restarting. so to actually halt I need to

sudo service rabbitmq-server stop
sudo halt

I just made an alias for it while this issue is fixed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.