Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've followed the steps outlined in this HowTo.

Right after I log in to Gnome I can move the mouse back and forth but as soon as the task bar loads, the mouse becomes jailed in the screen its in (can't move between screens).

This is my xorg.conf:

 Section "ServerLayout"
            Identifier     "Layout0"
            Screen      0  "DisplayLinkScreen" 0 0
            Screen   1  "Screen0" LeftOf "DisplayLinkScreen"
            InputDevice    "Keyboard0" "CoreKeyboard"
            InputDevice    "Mouse0" "CorePointer"
            Option     "Xinerama" "0" #Could not get this to work it has to be disable
EndSection

Section "Files"
 ModulePath   "/usr/local/lib/xorg/modules/drivers"
 ModulePath      "/usr/lib/xorg/modules/drivers"
 ModulePath      "/usr/local/lib"

 ModulePath   "/usr/lib/xorg/modules"
 FontPath     "/usr/share/fonts/X11/misc"
 FontPath     "/usr/share/fonts/X11/cyrillic"
 FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
 FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
 FontPath     "/usr/share/fonts/X11/Type1"
 FontPath     "/usr/share/fonts/X11/100dpi"
 FontPath     "/usr/share/fonts/X11/75dpi"
 FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
 FontPath     "built-ins"
EndSection

Section "Module"
 Load  "dbe"
 Load  "dri"
 Load  "dri2"
 Load  "extmod"
 Load  "glx"
 Load  "record"
EndSection

Section "InputDevice"
 Identifier  "Keyboard0"
 Driver      "kbd"
EndSection

Section "InputDevice"
 Identifier  "Mouse0"
 Driver      "mouse"
 Option     "Protocol" "auto"
 Option      "Device" "/dev/psaux" 
 # Option     "Device" "/dev/input/mice"
 Option     "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
 Identifier   "Monitor0"
 VendorName   "Monitor Vendor"
 ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"             # [<bool>]
        #Option     "SWcursor"            # [<bool>]
        #Option     "ColorKey"            # <i>
        #Option     "CacheLines"          # <i>
        #Option     "Dac6Bit"             # [<bool>]
        #Option     "DRI"                 # [<bool>]
        #Option     "NoDDC"               # [<bool>]
        #Option     "ShowCache"           # [<bool>]
        #Option     "XvMCSurfaces"        # <i>
        #Option     "PageFlip"            # [<bool>]
 Identifier  "Card0"
 Driver      "intel"
 VendorName  "Intel Corporation"
 BoardName   "Core Processor Integrated Graphics Controller"
 BusID       "PCI:0:2:0"
 Option     "DPMS"
EndSection

Section "Screen"
 Identifier "Screen0"
 Device     "Card0"
 Monitor    "Monitor0"
 SubSection "Display"
  Viewport   0 0
  Depth     1
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     4
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     8
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     15
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     16
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     24
 EndSubSection
EndSection

Section "Monitor"
    Identifier     "DisplayLinkMonitor"
EndSection
Section "Device"
    Identifier  "DisplayLinkDevice"
    Driver  "displaylink"
    Option   "fbdev" "/dev/fb0"
EndSection
Section "Screen"
    Identifier      "DisplayLinkScreen"
    Device          "DisplayLinkDevice"
    Monitor         "DisplayLinkMonitor"
    SubSection "Display"
        Depth       24
        Modes       "1920x1200" "1920x1080" "1680x1050" "1600x1200" "1440x900" "1366x768" "1280x1024" "1280x960" "1280x800"  "1280x768"  "1152x864" "1024x768" "800x600" "640x480" 
    EndSubSection
EndSection

Any help would be appreciated. I'm so close to getting this to work!

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 16:21

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
+1, I'm about to tackle this next week :) –  Tim Post Aug 2 '10 at 14:58
    
@Tim Good luck my friend. I still haven't gotten it to work. Hopefully the driver gods will smile upon you. –  Tyler Aug 3 '10 at 1:16

4 Answers 4

My best guess here is that the position of the right screen is causing the problems. you could try modifying the ServerLayout section like this:

Section "ServerLayout"
        Identifier     "Layout0"
        Screen         0 "Screen0" 0 0
        Screen         1 "DisplayLinkScreen" RightOf "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
EndSection

Or if you really want the DisplayLinkScreen to be the primary screen, modify it so that the coordinates match the resolution of Screen0. For example Screen0 has resolution 1900x1200:

Section "ServerLayout"
        Identifier     "Layout0"
        Screen         0  "DisplayLinkScreen" 1900 0
        Screen         1  "Screen0" LeftOf "DisplayLinkScreen"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
EndSection

Another possible location for the problems could be in RandR configuration which gets loaded during gnome startup. You can completely reset the RandR configuration by deleting ~/.config/monitors.xml.

share|improve this answer

You've got two different graphics devices, one with -intel, one with -displayport, and want to stitch them together so the mouse moves seamlessly across them. Xinerama is what stitches multiple screens together, so you need that enabled.

However, Xinerama mode for -intel is not really that well supported (should be getting better though). Maybe you'll be lucky with it, but afaik it's not expected that this should work.

You probably can get it to work if you use the -nvidia proprietary binary driver though.

share|improve this answer

I found a tool here that automatically wraps the mouse between separated screens.

It worked for me when I had trouble getting the mouse to move between screens.

share|improve this answer

However, Xinerama mode for -intel is not really that well supported (should be getting better though). Maybe you'll be lucky with it, but afaik it's not expected that this should work link.

share|improve this answer
    
The link appears to now be broken. Can you update it, or replace it with detailed information added to your answer? –  Eliah Kagan Aug 25 '12 at 21:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.