Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I get my ATI / AMD drivers to work with any kernel above 3.2.0.x ?


Installed original AMD64 version of Ubuntu 12.04 ISO image. Burned DVD and installed which shown kernel 3.2.0-23 to begin with. Got 5.1 surround sound working. Got ATI ( Now its AMD ) video drivers installed for my Radeon HD R6870 Video card from AMD's website. fglrxinfo came up and reported as normal.


Kernel 3.2.0.x kept locking up so I tried higher kernel versions. But ATI / AMD Drivers do not install on any kernel Above 3.2.0.x


I have gone over this tutorial many times ( ) and it doesn't work on ANY kernel except 3.2.0.x.

The problems I am having here are that the ATI / AMD drivers working for the 12.04 Precise with kernel 3.2.0-23 and 24, But the computer kept locking up. Although all my games would work, the lock ups were random and were constant. So I looked all over the web for 3 days trying to find an answer and the lock up issue was said to just update the kernel. So I did. Have tried many kernels. All of them .. no lock ups. BUT the Restricted AMD drivers from the AMD website will not install. And none of the OpenSource AMD drivers have EVER installed no matter what Kernel or version I tried.

at com.sun.opengl.impl.x11.X11GLDrawableFactory.glXGetConfig(
at com.sun.opengl.impl.x11.X11GLDrawableFactory.xvi2GLCapabilities(
at com.sun.opengl.impl.x11.X11GLDrawableFactory.chooseGraphicsConfiguration(
at haven.HavenPanel.<init>(
at haven.HavenPanel.<init>(
at haven.MainFrame.<init>(
at haven.MainFrame.main2(
at haven.MainFrame.access$100(
at haven.MainFrame$

And of course this is what fglrxinfo shows :

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  139 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13

EDIT : I forgot to mention that I DID look at this post over the last few days and it did not help.

share|improve this question
Yes, great job! I don't know if I can help but I upvoted your question so hopefully someone who can help takes a look at it sooner rather than later. – izx Jun 12 '12 at 23:26
Ahh ok appriciate your help. I'm still trying to solve it. In the meantime, I am running Mint 13 Cinnamon with 3.2.0-23 kernel and so far its stable as long as I do not install the drivers. There are no ATI drivers running on my system yet. I must be running pure Xorg at the moment. I can even run my JAVA 3D games. But its lousy graphics. So I hope the ATI driver situation gets fixed or I’ll be forced to go back to crappy windows. Not looking forward to that. :-/ – TorakTu Jun 13 '12 at 22:30
Ubuntu drivers are typically for the Ubuntu kernels only. IMO you're better off resolving your lockup issue first on 3.2 WITHOUT the ATi drivers and then install them. – izx Jun 13 '12 at 22:35
Yea so far, I think I got it as far as the lock ups on 3.2.x. I didn't upgrade to the 3.2.0-24. I am still on 3.2.0-23 and so far no lock ups with Mint 13 Cinnamon. Its the only Linux version that doesn't lock up. HOWEVER I still cannot install the AMD drivers without it starting to lock up. So as long as I do not install video drivers I am good. But that also means all my games are slow and not all 3D games work. So back to windows I go I guess. I am left with no choice. – TorakTu Jun 14 '12 at 14:26
@TotakTu have a look at my accepted answer to this question.…. i looked over the instructions you were using and there are differences, you may not have installed all the correct dependencies etc. – stephenmyall Jun 19 '12 at 14:01

There are two driver options that usually work well:

  • the opensource radeon driver
  • the fglrx package from the official repository

A 64-bit kernel usually gets much better support in this case.

You can also try the 12.6 beta drivers from AMD.

If you need a guide, try the Unofficial Wiki for the AMD Linux Driver.

Do not install a new driver package over an old one. Remember to uninstall the previous package(s).

share|improve this answer
Yes, I just tried this version. I still get the same error I always get "DKMS part of installation failed. Please refer to /usr/share/ati/fglrx-install.log for details". So far no one has fixed the problem for my video card. I am seeing a pattern however. I am using the newer R ( Hawk Edition ) of the R6870 from MSI. Apparently it doesn't use the same regular drivers as the regular older 6870 version. Even though they have the same type of core. I am wondering if that's the problem. – TorakTu Jul 8 '12 at 19:03

I'm running Ubuntu 12.04 with kernel 3.2.0-26 and had a nightmare getting the ATI and catalyst drivers installed. I'm running a Radeon hd5xxx card and had tried and failed to install the drivers. This is what worked for me as I had a broken installation that wouldn't reinstall and gave me the same DKMS error.

I also followed the binary driver, but as it relies on the uninstall being OK, which mine wasn't, it was useless and refused to fix my driver. I finally amalgamated several fixes from different sites to get mine working.

I did this after using recovery console to get some display back. I had access to synaptic at the time so hopefully you have access.

First thing I did was to add a repository and added all the updates. Graphics failed as I expected.

sudo add-apt-repository ppa:gnome3-team/gnome3 

This added some libs that the main repository didn't have and fixed a few other issues too.


  1. sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.BAK - for safety

  2. sudo rm /usr/share/ati/ - stops the purge from failing without doing anything at all.

  3. sudo apt-get remove --purge fglrx* (Had errors but carried on)

  4. sudo rm -rf /usr/share/lib/fglrx

  5. sudo rm -rf /usr/share/lib32/fglrx

  6. open synaptic and mark fglrx for installation. This finally added the driver.

  7. with synaptic again, add the ATI catalyst control center.

After reboot, I had issues with my dual screens but as catalyst was installed, I fixed this and now everything works. It even sorted out a flashing I got when moving windows across the dual screens or when activating rotation of desktop cube.

share|improve this answer

The new AMD 12.11 beta drivers (released 2012.10.23) will work with newer kernels (in my case they are working with 3.5). However to install them you must first install linux-headers-generic. Hence:

    sudo apt-get install linux-headers-generic

You will have to reinstall them from the command line every time you have a kernel update (ctrl+alt+F1 to get to a console in low-graphics mode).

Run the driver as sudo, and use the --force option, e.g.:

    sudo ./amd-driver-installer-catalyst-12.11-beta-x86.x86_64 --force

P.S. This script will get rid of the watermark.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.