Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Can I tweak or configure Radeon driver to reduce overheating. My GPU gets 70-80C temp on start. I don't want Catalyst by now because they are very slow for 2D.

using mobility hd4570, Ubuntu 12.04 x64 3.2.0-24-generic.

share|improve this question
    
Not as far as I am aware with impacting performance, but why is your GPU getting 70C-80C temps on start? What are you using to measure temps? You might be able to undervolt the card in the BIOS if it really is running that hot. That's absurdly hot. –  phthano Jun 12 '12 at 14:18
    
using Psensor to monitor the temp. since 10.04 I've always had high temp on my GPU with open source driver. Catalyst reduce the temp to around 60C in desktop mode. Also I'm using juputer to set power mode on demand but the GPU temp get down to 70C only when I unplug AC power. Yesterday I clean my fan dust and put new Thermal Grease on cpu and gpu. –  Tosho Jun 12 '12 at 14:32
    
Have you set the power management mode for the ATI Radeon driver? (separate from the CPU governor) There's several online guides, but the basics are this: In a terminal, run sudo su, then echo mid > /sys/class/drm/card0/device/power_profile [one line] (Other valid modes are auto, which uses high when plugged in and mid on battery, high, which forces full performance, and low, which saves the most energy, but might not work on some hardware) –  Shane Jun 15 '12 at 16:51
    
I did try echo low > /sys/class/drm/card0/device/power_profile and others from https://wiki.archlinux.org/index.php/ATI#With_KMS_enabled. It lowers the GPU temp around 60C but after restart the temp gets high again. Can this be used as a command in startup ? –  Tosho Jun 18 '12 at 10:51

4 Answers 4

up vote 6 down vote accepted

Tosho, I had exactly the same problem about setting the power_profile at startup and keeping it thourgh supend-resume applying the common solutions (as described here) and finally found a working alternative solution using pm-utils. I'm not sure if it is the best way to do it (I'm new to Linux) but it does all I wished for: Set the radeon power_profile to low on boot and retain that setting after suspend-resume.

Step 1: Create hook

gksudo gedit /usr/lib/pm-utils/power.d/radeon-power_profile

Step 2: Fill in the desired setting

#!/bin/sh

echo profile > /sys/class/drm/card0/device/power_method
echo low > /sys/class/drm/card0/device/power_profile

exit 0

Step 3: Make it executable

sudo chmod +x /usr/lib/pm-utils/power.d/radeon-power_profile

That's it :)

share|improve this answer
    
this one works! thank you. interesting why? why the previous answer and editing rc.local do not work? –  Tosho Aug 9 '12 at 15:23
    
Honestly, I have no idea, but I will try the rc.local-solution again after the next upgrade. For now I'm just happy, my GPU isn't overheating any more :) –  Precise Penguin Sep 2 '12 at 9:04

I was having a similar problem where my Mobility Radeon HD4570 was running extremely hot (idled at 84 degrees) and ran considerably hotter than when running Windows. I used Jockey (aka Additional Drivers from the Dash) to install the proprietary drivers and rebooted, and I'm now seeing a drop of around 20 degrees on my previous temp's so this may be worth trying.

Hope it helps

share|improve this answer
1  
I'm aware of proprietary drivers but I don't want to use them. I don't like the desktop performance with Catalyst. That's why I want to use radeon open source drivers. –  Tosho Jun 13 '12 at 9:31
    
In that case, I don't know of any way to lower the temperature of your GPU, while sticking with the open-source driver. I haven't actually noticed any degradation in performance with the fglrx drivers, so it's really a personal choice. –  agc93 Jun 13 '12 at 14:52
$ cat /etc/udev/rules.d/30-local.rules

KERNEL=="card0", SUBSYSTEM=="drm", DRIVERS=="radeon", ATTR{device/power_method}="profile", ATTR{device/power_profile}="auto"

Where ATTR{device/power_profile}="auto" can be (source: https://wiki.archlinux.org/index.php/ATI):

  • "default" uses the default clocks and does not change the power state. This is the default behavior.
  • "auto" selects between "mid" and "high" power states based on the whether the system is on battery power or not.
  • The "low" power state are selected when the monitors are in the dpms off state. "low" forces the gpu to be in the low power state all the time. Note that "low" can cause display problems on some laptops; this is why auto only uses "low" when displays are off.
  • "mid" forces the gpu to be in the "mid" power state all the time. The "low" power state is selected when the monitors are in the dpms off state.
  • "high" forces the gpu to be in the "high" power state all the time. The "low" power state is selected when the monitors are in the dpms off state.
share|improve this answer

alt-f2:

gksudo gedit /etc/init.d/ati-power-save

write this in ati-power-save file:

#!/bin/sh

# ATI power save
echo profile > /sys/class/drm/card0/device/power_method
echo low > /sys/class/drm/card0/device/power_profile

save and run these commands:

sudo chmod +x /etc/init.d/ati-power-save 
sudo update-rc.d ati-power-save defaults 99

as described in here

share|improve this answer
    
I did this but still is doesn't work for me. the power_profile stay the same - "high" –  Tosho Aug 9 '12 at 14:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.