Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been pulling my hair out trying to get Oracle Java running in Chromium. My Java version is shown below:

java version "1.6.0_32"
Java(TM) SE Runtime Environment (build 1.6.0_32-b05)
Java HotSpot(TM) Server VM (build 20.7-b02, mixed mode)

In my bash_profile I have:

export JAVA_HOME=/usr/lib/jvm/jdk1.6.0_32 
export PATH=$PATH:$JAVA_HOME/bin 4

I've tried linking as below:

ln -s $JAVA_HOME/jre/lib/i386/libnpjp2.so /usr/lib/chromium-browser/plugins

I had it working and then upgraded to 12.04, and am now stuck.

share|improve this question
add comment

2 Answers 2

I used to link the libnpjp2.so as /usr/lib/mozilla/plugins/libnpjp2.so and ~/.mozilla/plugins/

EDIT: Where to download and how to install the sun java plugin

share|improve this answer
    
No difference. I tried starting with --enable-plugins also, but still no sigh of Java in about:plugins. –  Tom Eustace Jun 12 '12 at 13:35
    
I'd be happy if I could get it working in Firefox either. –  Tom Eustace Jun 12 '12 at 13:50
    
@TomEustace : I added the link from where I found the detailled explanations to install sun java plugin. –  Cédric Julien Jun 12 '12 at 13:57
    
ok, I had the plugin enabled for jre 1.7.04 in chromium by following the instructions. I now just need to get it working for jre 1.6.32 as that is what I require. jre 1.7.04 was located in /opt/java/64. I am using a 64 bit system but require 32 bit jre. –  Tom Eustace Jun 12 '12 at 15:55
    
I have purged openjdk. I now have only oracle jdk 1.6.32 installed. I run the various commands to link to Java plugin but still not working. Java is installed at /usr/lib/jvm/jdk1.6.0_32. I've updated alternatives to point to this version. I must be missing something!! –  Tom Eustace Jun 12 '12 at 21:31
show 2 more comments

I finally got it working by running the commands from this link for amd64

sudo apt-get remove firefox openjdk-6-jdk icedtea-6-plugin
sudo apt-get install firefox:i386 openjdk-6-jdk:i386 icedtea-6-plugin:i386
share|improve this answer
    
Welcome to Ask Ubuntu! I'm assuming you're the same person as the OP, if so, please accept this answer to mark this post as solved. Thank you. –  Peachy Sep 27 '12 at 14:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.