Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use Kubuntu 12.04 with KDE 4.8.3 and wodim / genisoimage 1.1.11, but the problem is on Ubuntu (with Brasero) and occurred in Oneiric as well.

Whenever I try to burn more than 3.8GB (approaching the 4 GB limit) of data onto a DVD, burning fails, aborts, or gives an "error 254."

I have lost more than 50 DVDs this way until I learned about the 3.8GB limit. Anything under 3.8GB burns fine, and DVDs burned with more than 3.8GB have usable data up to 3.8 GB, but then the remaining data is garbled, unaccessible, or the disk is just not recognized.

I'm pretty certain this is related to the replacement of cdrecord / mkisofs with wodim /genioimage (which is a problem that has been described for years). Is there another answer or fix? Re-installing cdrtools/cdrecord/mkisofs in Oneiric and Precise has become a herculean task.

share|improve this question
1  
A single layer DVD can Hold up to 4.7 GB. Can you explain more. – Mitch Jun 12 '12 at 11:53
    
You could try to use a USB instead, if possible. – Alvar Jun 12 '12 at 12:25

This may possibly be a user issue or a 12.04 issue. I just burned a 4.02gb DVD last night on 14.04LTS(ISO, one file), and have several times burned 4+gb general file DVDs using Brasero, and have had no data loss or errors as a result. The only problem I have ever had was trying to use Brasero in writing video files (due to other dependencies related to video time stamps). Brasero gags on time stamps really badly.

Then again, terminal command line mkisofs is the best way to handle writing video DVDs, anyhow.

just create a directory called 'junk', with two sub-directories, 'VIDEO_TS' and 'AUDIO_TS', copy your target files into the video_ts folder, then:

mkisofs -dvd-video -o junkimage.iso junk/

this will make you an ISO image of the DVD that you can burn however you want to. If you get errors, check 'askubuntu' for video format errors and PAL vs NTSC format setting, as well as looking up what the significance of the Video Manager Information File has.

FOLLOW-UP: Ok, I took an old video DVD, placed it on my harddrive (in DVD .VOB/.IFO structure, with .BUP files too), total size was 7.9-gb on-drive.

Then, using mkisofs, I followed the generally accepted practice as follows:

  1. Made DVD folder named 'DVD' (HOME/TEMP/DVD)
  2. Created two sub-directories, VIDEO_TS and AUDIO_TS (beneath the structure explained in step 1).
  3. Placed all .IFO and .VOB files in VIDEO_TS (if you have audio files too, like .AUP, they go in the audio sub-directory), leaving the .BUP and management files in the /DVD folder itself.
  4. opened TERMINAL, went to the directory given in step 1
  5. type in the command: mkisofs -dvd-video -o dvdimage.iso dvd/ (you will change the .ISO filename and the dvd/ folder, depending on the name of your dvd. If your dvd was named TROLL, then the command would be: mkisofs -dvd-video -o TROLLimage.iso TROLL/
  6. Now, I have a 7.4-gb ISO image sitting in 'home/temp' by the name of dvdimage.iso
  7. Open Brasero and select the last button (BURN IMAGE), choose your ISO file, choose your destination (ideally, your DVD drive), and accept. When done, you now have a new burn of a video DVD that will play in a DVD player or DVD drive

My test on a 7.4-gb .ISO onto a DVD+R(DL) dual layer disk (capacity 8.5 gb) was successful, and I did play the movie afterwards (I also wasted almost 2-hours watching the movie, afterwards!)

I did get one initial error when my typing hand decided that I spell 'dvd' as 'dwd', but a quick OPERATOR ERROR check fixed it...Ubuntu performed flawlessly, as did Brasero.

If you get errors, look hard at yourself first, then make sure that you have PAL or NTSC (as may be required in your region) set properly, if required. Also, if you are not placing your appropriate files in the right place during the mkisofs process, you are mostly likely failing at this point. Remember, you must build your directory structure first, to successfully use mkisofs for video dvd processes.

share|improve this answer
  1. Try other programs, i.e. gnomebaker or simpleburn:

    http://simpleburn.tuxfamily.org/ -- https://launchpad.net/~simpleburn/+archive/ppa

    http://sourceforge.net/projects/gnomebaker/ -- https://launchpad.net/~gnomebaker/+archive/stable

  2. There are different types of DVDs that support different capacities. According to the wikipedia article (Capacity and nomenclature of (re)writable discs), there are two versions of DVD-R discs, ~3.68 GiB and ~4.37GiB (Don't look at GB, but GiB, that's the actual data capacity).

    Always look at what's printed on the DVD, they usually mention if they're DVD-R or DVD+R. If they don't mention anything (i.e. no-named), don't buy them, unless you're up for the risk.

    Prefer DVD+R (no specific reason, but if you need one, they don't have 2 versions and are 4.37 GiB in capacity).

    You could also try the dual layered dvds, which provide ~8 GiB in capacity.

    For testing purposes buy 2-3 DVD+RW discs.

  3. Burn at low speeds, 4x recommended.

  4. Devices such as dvd burners die eventually (at least in my case), after 2-3 years they become faulty. For example, burning worked in my case, except that I couldn't boot using any cd/dvd media. I bought a new CD/DVD burner and recycled the old one. Now the new one after 2 years burns only at speeds lower than 10x. Go figure. :)

share|improve this answer

I have had numerous problems with the CD burning software on Ubuntu. Only one option eventually satisfied me (but unfortunately it is not open source): Nero Linux 4. Nero offers a free 30 trial before you have to buy. I don't know if Nero will solve the problem you are experiencing or not. But it being propietary might bypass whatever is causing the problem on Ubuntu?

What I would recommend is to try K3B on Ubuntu. You will have to install the KDE libraries to install K3B though. If K3B does not work for you, I would try Nero. Nero for Linux did everything I asked and had all the options I was looking for.

I'm hoping that the poor quality and dearth of features of the open source CD burning options will be addressed at some point for Ubuntu because I don't like having to use closed source stuff. But, unfortunately, I have not found a better alternative for CD burning on Ubuntu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.