Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I executed the shell script given in How do I delete kernels from a server?. It deleted old kernels but not their associated kernel entries in the Grub 2 menu. For example, the shell script did not remove the Grub 2 entry »Ubuntu, mit Linux 3.2.0-24-generic (Wiederherstellungsmodus) (on /dev/sda8)« and »Ubuntu, mit Linux 3.2.0-14-server«.

share|improve this question
    
did you tried sudo update-grub command after deletion –  Anwar Shah Jun 12 '12 at 10:50
    
apt-get autoremove should do the trick. –  turbo Jun 12 '12 at 11:03
    
Anwar Shah: I did '~$ sudo update-grub'. It did not help: No change. -- turbo: I did '~$ sudo apt-get autoremove'. It did not help: No change. -- –  user43816 Jun 12 '12 at 11:37

2 Answers 2

Grub2 is a step forward in a lot of ways, and most of the annoying menu.lst issues from the past are gone. Still, if you’re not vigilant with removing old versions of the kernel, the boot list can still end up being longer than it needs to be.

This site (from which that's quoted) provides a complete tutorial on how to do this.

share|improve this answer
    
Mitch: I performed what is recommended in howtogeek.com/howto/17787/… . With me there are 9 files in /etc/grub.d/ . No file of them mentions my superfluous Grub 2 entries. -- So: No help. –  user43816 Jun 12 '12 at 12:06

The best tool that I've found for Grub2 (and Burg) management is Grub Customizer.

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

As shown in the image below, you can specify the order of kernels, the default kernel to run, and even manually add grub parameters. (I happen to be using burg, but burg is just a graphical wrapper for grub, so the config is the same). Screenshot

  • For more information, see this review of Grub Customizer on webupd8.org.
share|improve this answer
    
I installed grub-customizer using the commands which you suggested. Grub customizer - settings does not list all kernel entries which I'd like to get rid of. I tried to delete one unwanted kernel entry which Grub Customizer did list. But even this one stays put (after applying the procedure suggested and rebooting). –  user43816 Jun 14 '12 at 14:52
    
I was able to delete the misleading kernel entries using command line commands only and no additional tools. I have 2 Ubuntu systems on my computer. I recognized that these mutually prevented removing the misleading Grub 2 kernel entries. -- I used the commands '$ sudo grub-mkconfig -o /boot/grub/grub.cfg', /etc/default/grub GRUB_PROPER_OS=false and /boot/grub/custom.cfg . –  user43816 Jun 15 '12 at 4:28
    
Cool. I'm glad you figured it out. You should post that as an answer and accept it so that this question gets closed. –  Senoculus Jun 15 '12 at 11:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.