Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a machine (Ubuntu 11.10) that I would like to have it play audio (typically through an amplifier), but the machine should be headless (where its final placement will be). I will control what is played through ssh.

However, there is no sound output until I login to the graphical console. At first I thought it was an issue with pulseaudio, so I promptly removed it to use the default ALSA, but I have the same issues. I ssh to the machine, I run alsamixer and get the typical cannot open mixer: No such file or directory error (while /proc/asound/cards display correctly what I have). If I login on the graphical console, alsamixer works fine in the ssh session, and I have sound output. I logout, and then alsamixer stops working. So something runs (Xsession perhaps?) when I login that enables sound output, and gets disabled when I logout.

I remember in older versions of Ubuntu, there was a drum roll when the machine showed the login screen; that is not the case anymore. Perhaps if I somehow can enable that drum roll, I'll have fixed my problem too.

In any case, the question I ask is what the title says.

UPDATE: issue still unsolved. I just wanted to note the information that sound is configured correctly and enabled whether I log in to a Gnome or a XFCE environment, and de-configured and disabled when I log out.

share|improve this question
    
I'm sure that someone will suggest to turn on automatic login, which I know about, but I'd really like to know what needs to be done to have sound before logging in. –  ΤΖΩΤΖΙΟΥ Jun 12 '12 at 10:39

1 Answer 1

up vote 1 down vote accepted

Well, I found the answer when I attempted to run alsamixer et al. under sudo (in which case, they run). I had to add the remotely-connecting user to group audio (which had only user pulse from the previous pulseaudio installation).

It really would be more helpful if the various ALSA tools reported something EPERM/EACCES related instead of ENODEV/ENOENT.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.