Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

after upgrading to ubuntu 12.04 lts browser (firefox, chrome) does not load webpages. Connection to the network works and also to the internet (skype is working) Software installaion via sudo apt-get fails ( -5 hostname association ...)

share|improve this question
4  
This seems like it's caused by a bad HTTP proxy server, since both apt-get and your web browser use HTTP, but Skype does not. Hopefully someone with extensive experience using and troubleshooting HTTP proxies on Ubuntu can post an answer... –  Eliah Kagan Jun 12 '12 at 17:56
    
I have been going crazy with this same issue. I found this possible solution having to do with turning off ipv6 but it did not help me ubuntuforums.org/showthread.php?t=1978398 –  max Aug 31 '12 at 11:29
1  
What do you get you you type traceroute google.com in terminal? –  Mitch Sep 4 '12 at 5:44
add comment

3 Answers

This could be to do with your DNS settings. Are you getting any error messages back from either browser or terminal?

You should pick up your DNS setting from your router/default gateway which in turn picks it up from your ISP. Try editing the connection to use a external DNS. One that I always use is 8.8.8.8 and secondary of 8.8.4.4 which are run by Google. Other options available are OpenDNS.

Ideally this would be some that would be programmed into your router so that your whole network behaves the same other you may have to fix this on each workstation.

Note: This can have issues on your local network if you need to resolve something internally.

share|improve this answer
add comment

I know that this might not be the answer that you're looking for, but since I don't have the outcome of traceroute google.com, I will suggest some things that you can try.

  • Disable IPV6
  • Change default DNS to Google Public DNS (8.8.8.8 and 8.8.4.4)
  • Try pinging ubuntu.com and both Google DNS Servers (8.8.8.8 and 8.8.4.4)
  • Check to see if Java is installed properly
  • uninstall Chrome, and install Chromium. sudo apt-get remove google-chrome-stable, and install Chromium from the Ubuntu Software Centre.

  • Check to see if flash is installed properly

  • DNS prefetching

DNS prefetching is performed to resolve domain names to IP addresses while loading web pages. To disable DNS prefetching, create a new Boolean preference named network.dns.disablePrefetch in about:config and set it to true, as follows:

    Type about:config in the address bar, press Enter.
    Context click (right-click) in the preferences list and select "New -> Boolean".
    Type or paste in the preference name network.dns.disablePrefetch and click OK.
    Select true as the value and click OK. 
If this doesn't help you can re-enable DNS prefetching by resetting the preference to "false" (double-click to toggle).

Source:Mozilla

  • Managing DNS Entries

To manage DNS entries, you can modify DNS names from the /etc/resolv.conf file

share|improve this answer
    
Why remove chrome and install chromium? –  NlightNFotis Sep 6 '12 at 8:17
    
Chromium is the base for chrome. Chrome is the Chromium open source project built, packaged, and distributed by Google. –  Mitch Sep 6 '12 at 8:40
add comment

=>Clear all the browser related items like cookies, history and bookmarks.

or

if first one is not working then follow second.

=>Make an installation of your browser again. remove your existing installed browser.It will help you to cover all those files which are corrupting your browser.

share|improve this answer
3  
apt-get is not working, so why would you expect anything specific to a web-browser to help this problem? –  Eliah Kagan Jun 12 '12 at 17:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.