Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've add this following code to /etc/polkit-1/localauthority/50-local.d/com.ubuntu.desktop.pkla

[Enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

When i choose to hibernate, the pc doesn't shutdown but i can see the text in the image in the link...

enter image description here

Help me please..I need to hibernate my computer.. Thanks

share|improve this question
2  
Please edit your question to include the model # of your laptop, thanks! –  Jorge Castro Jun 12 '12 at 1:18
add comment

2 Answers

nouveau is the built-in (open source) driver for Nvidia graphics cards. What the error is telling you is that nouveau had trouble getting the Nvidia card to go into the power state necessary for the system to hibernate.

Two possible solutions:

  1. Try the binary Nvidia drivers instead (go to System Settings...Additional Drivers); if that doesn't work try the different versions of Nvidia drivers that may have worked for others with your specific card series/model (google, search askubuntu, etc.)

  2. See this answer on how to try an alternative hibernation method (TuxOnIce) which is reported to be compatible with a wider variety of hardware. Of course, it may or may not work....

share|improve this answer
add comment

You can check my post on this http://arecordon.blogspot.com.ar/2013/08/ubuntu-enabling-hibernation.html

You might need to update GRUB. There's also a test that you can run to make sure the hibernation works Ok.

Please, let me know if it worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.