Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello all. My Ubuntu 11.10 installation seems to suddenly lock up. I cannot move my mouse or use the keyboard, all screen activity stops, and I have to do a hard reboot. Is there an y method to repair this? It started a few days ago.

share|improve this question

closed as off topic by fossfreedom Jun 12 '12 at 19:46

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Jorge Castro Jun 12 '12 at 19:31
1  
@JorgeCastro In my opinion, this is not a bug, but a valid question(I assume you thought of a memory leak), but this is a user trying to get help with freezing(containing instructions that other users may use to diagnose constant hangs) and possibly adding badram addresses to the grub config to avoid bad areas. –  hexafraction Jun 12 '12 at 20:22

1 Answer 1

Before you panic, try the magic SysRq trick. Find the key on your keyboard labelled PRT SCRN|SYSRQ(Could be arranged differently). Hold that key, ALT and M. This invokes the Linux oom_kill which could aid in recovering. Also, try this with B instead of M and see it it reboots then. If it does, then you are either out of memory(If you have a swap partition, your disk may be active), or you have another software issue. If not, it is hardware. Try pressing CTRL+ALT+F1 during the freeze. Does that work? If so, you can use top after logging in to ascertain the process causing the issue.

Try running vmstat 1 in the Teminal. In a comment, tell us your swapin and swapout values.

Also ,try running top, giving us the top %CPU values, then pressing SHIFT+O, then Q or T, then ENTER. and the RSS and SHR values of the top processes. This can help pinpoint the cause. Also, are you using Skype, by any chance? There is a reported memory leak in it.

share|improve this answer
    
I followed your first instruction and the only thing my OS did was it captured the screen couple of times –  Alen Jun 11 '12 at 20:48
    
swapin 0 swapout 1484, that's the min and max values. top - 23:02:36 up 10 min, 1 user, load average: 1.64, 1.76, 1.20 Tasks: 155 total, 3 running, 152 sleeping, 0 stopped, 0 zombie Cpu(s): 4.0%us, 2.2%sy, 0.0%ni, 92.9%id, 0.7%wa, 0.0%hi, 0.3%si, 0.0%st Mem: 993648k total, 895432k used, 98216k free, 89128k buffers Swap: 1013756k total, 11072k used, 1002684k free, 190168k cached –  Alen Jun 11 '12 at 21:02
    
I have skype installed but not using it –  Alen Jun 11 '12 at 21:03
    
did I provide you with all information you need? –  Alen Jun 11 '12 at 21:44
    
Were you holding ALT when tried to use the key combo? Or do you have a separate SysRQ key? Also, is the info about memory from after the lockup or before(using the terminal given with ctrl +alt+F1)? Were you able to switch to a terminal using that key combo? –  hexafraction Jun 11 '12 at 22:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.