Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since dist-upgrading 12.04 LTS in such a manner as resulted in an upgrade of GNOME from 3.2.x to 3.4.1, auto_raise is broken.

I have the usual auto_raise* settings set in gconf, in apps -> metacity -> general. But the functionality just doesn't work anymore.

Focus follows mouse works fine, yes, but windows just no longer raise after a short delay. I have tried both gconf and tweak tool-based remedies, to no avail.

Any ideas on how to work around this? Auto-raise is a really integral part of my workflow.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

I think this is because gconf-editor is being phase out in favor of dconf-editor. I had a similar problem (actually the opposite, I was trying to disable auto_raise and it wouldn't work). It seems that the setting in gconf-editor is overwritten by the setting in dconf-editor.

sudo apt-get update
sudo apt-get install dconf-tools
dconf-editor

Navigate to org/gnome/desktop/wm/preferences.

share|improve this answer
    
It worked! Thank you SO much! –  Alex Balashov Jul 1 '12 at 4:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.