Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Unity doesn't load, no Launcher, no Dash appears

Ever since I downloaded Ubuntu 12.04 my computer basically has been really screwed up. Loading up ubuntu in regular mode has a blank screen with my background and that's it, and so i'm in 2D mode.

share|improve this question

marked as duplicate by Jorge Castro, Eliah Kagan, jokerdino, hexafraction, Jjed Oct 1 '12 at 13:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
You need to give more information. “Basically been really screwed up” is not informative. What happens when you type sudo dpkg-reconfigure lightdm in a terminal`? Copy-paste the output. –  Gilles Jun 11 '12 at 19:17
    
it asks for my password, which I can't give because it doesn't allow me to type it (the letters don't appear) –  Max Jun 11 '12 at 19:19
    
It's normal for the letters not to appear: passwords are not shown, in case someone was looking over your shoulder. What happens if you type your password and press Enter? –  Gilles Jun 11 '12 at 19:20

1 Answer 1

up vote 3 down vote accepted

The solution to your "my desktop is blank in Unity (3D)" is simple, but involves using an advanced tool, Compiz Config Settings Manager.


Warning: Compiz Config Settings Manager is an advanced tool and one tiny mistake, typo or an accidental click of the mouse can leave your desktop unusable, requiring time and effort to fix it. Please be very careful and follow instructions...thanks. Once you are done using it, please consider uninstalling/removing it to reduce future risk. If you mess up, please see this answer on how to fix things.


  • Install CompizConfig Settings Manager with sudo apt-get install compizconfig-settings-manager in Ubuntu 2D, if you don't already have it.
  • Logout and log in into Ubuntu (3D)
  • Right click on the blank desktop, create a new folder.
  • Click on "File System" on the left sidebar, and navigate to /usr/bin. Scroll down to CCSM and double-click to run it:

    enter image description here

  • Type unity in the Filter box and click on the Unity Plugin:

    enter image description here

  • Just check the "Enable..." box on the bottom left and you should have your normal 3D environment back:

    enter image description here

share|improve this answer
    
When I try to install the first thing it asks for my password but when I type the password in the terminal it doesn't appear –  Max Jun 11 '12 at 19:21
    
The password is never shown for sudo, even as *****. Just type it and press enter! –  izx Jun 11 '12 at 19:22
    
Explains so much...lol Thank You! –  Max Jun 11 '12 at 19:22
    
the box was already "enabled" but I don't have my 3d environment back, what's the problem? –  Max Jun 11 '12 at 19:46
1  
@MartyFried, many thanks for the reminder, agree completely, see bold warning added on top :) –  izx Jun 11 '12 at 20:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.