Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed 10.10 from a minimal iso. I've installed gnome-core and the network manager (among a few other things), and I've added the notification area to the panel.

According to the system monitor, nm-applet is currently running, but I can't see it in the notification area. How can I resolve this?

EDIT:

I've noticed that if I click really close to the right of the notification area I get a nm-applet dropdown box but it says "device not managed" under "Wired Network" (I am connected to the internet though), yet there is no nm-applet graphic.

share|improve this question
1  
Are there other icons in the notification area that are displaying? –  Nathan Osman Nov 26 '10 at 4:29
    
Nah, there aren't. But the indicator applet and clock are there. –  oadams Nov 26 '10 at 5:10

4 Answers 4

up vote 5 down vote accepted
+50

If you see "device not managed" then probably your NIC is indeed not managed from network-manager.

Please check the following file:

/etc/NetworkManager/nm-system-settings.conf

What does the following section say ?:

[ifupdown]
managed=?

if it's set to "false", switch it to "true", save the file and run a:

"sudo service network-manager restart"

share|improve this answer
    
Thank you so much. –  oadams Dec 1 '10 at 4:20
    
You're welcome :-) –  Pavlos G. Dec 1 '10 at 9:04
    
thanks, this really helped me out –  Tomba Mar 2 '11 at 17:52

Ok I tracked down a Ubuntu forum Thread about it here

nm-applet icon missing from panel

One of the solutions which hasen't been mentioned here is the work around mentioned in launchpad.

OK, weird, I haven't had this problem for a couple of days now. The thing I did was to right click the panel, select 'properties', and then disable 'expand', wait till the panel resizes and then enable 'expand'

Try this one and if it doesn't work there are a few others in post.

Hope this help's

share|improve this answer
    
I just gave that a go. Alas, it didn't fix the problem. –  oadams Nov 26 '10 at 23:40
    
The other solutions in the thread didn't help. I tried the one that involves going into network connections, but there isn't any connection to select. –  oadams Nov 28 '10 at 2:40

You probably don't have Notification area since you did a minimal install.

All you need to do it to right click on the top panel, "Add to Panel" and search for "Notification area" and you can see NetworkManager applet reappear.

I can't confirm this since right now I am not on an Ubuntu machine, but this is a known problem. People usually come across this and even including me

share|improve this answer
    
I had added the notification area. –  oadams Nov 26 '10 at 6:14

According to your edit, maybe the notification area has been resized so small that it can't show the nmapplet inside it. Try unlocking it and moving it around, or add some other icon to the panel and see if it shows up.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.