Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've made a clean install yesterday, for the first time restarted, everything went good and then after I updated packages and copied my old home directory to replace the new one, when I restarted it hung when it was booting. I tried reinstalling again and doing the same thing, but again same thing happened.

Here's what I see, before when the Ubuntu logo with the five dots is shown: enter image description here

Then after that, 3 or 4 of the dots will load and hangs there. If I press arrow up before that, this will be shown enter image description here

I started my laptop again today(the pictures are for the day before) and after that, boot up with live CD and got the logs.



And some info:

alfred@alFitop:~$ uname -a
Linux alFitop 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux


sources.list :

My problem is a bit similar to here: Though I didn't change my config. Only changed home directory and updated packages.

I've tried memtest and fschk, both passed.

In the recovery mode boot option, I've also realized that same things happen in failsafe graphical mode. But when I go into the network mode, I can boot up my system, but of course same the graphics are just basic.

Adding blacklist intel_ips to /etc/modprobe.d/blacklist.conf solves the first message, but still I get the broken pipe and CPU stack traces.

The current kernel version is 3.2.0-25, I've tried booting up in the 3.2.0-23(the one the installer came with, but same results.)

Also uninstalled apparmor, didn't help. I've installed Ubuntu again, this time without copying the home directory, also same result.

--- UPDATE ---

This problem was solved before with removing backports, but its back again! I've updated my laptop last night and the problem came back. It's definitely one of these packages.

My /var/log/apt/term.log and /var/log/apt/history.log.

I'm almost having the same situation.

--- UPDATE ---

I realized this also have happened on times that I have updated(haven't restarted after it) and my computer power has been cut off and its shutdown due to lack of power. And I realized if I just do as I answered but not in somewhere without GUI(networking mode has the GUI) it wouldn't work.

share|improve this question
up vote 1 down vote accepted


This thing also happens, when I update and then cut the power. I realized if I just boot into networking mode and then restart it just works, if that didn't work try the solution below:

So the problem was about a package, since it only happens after I update the packages. So I tried to remove backports from sources.list and it just worked(credits to the idea goes to manesh)!

What I exactly did, I booted up into networking mode from recovery mode(weirdly it just worked, would be nice if I someone explains to me, why that works but can't boot up normally, tried chrooting from live CD but most commands returned no premission to /dev/null. Would appreciate it if somebody explains that too.), commented backports and just did the following:

apt-get update
apt-get upgrade
apt-get install -f
apt-get autoremove
apt-get autoclean
share|improve this answer

Boot into recovery mode:

Switch on your computer while grub is loading depress ESC. At the boot menus select 'Ubuntu, kernel 2.6.17-10-generic (Recovery mode)' and press ENTER to continue with the boot process.After the process scroll down to 'Drop to root shell prompt' and type the following commands below.

  1. sudo gedit /etc/modprobe.d/blacklist.conf

  2. blacklist intel_ips

And, reboot your system.

share|improve this answer
With the fact, that recovery mode would give us a readonly file system and you have to mount it to make it writeable and there's no X running, so running gedit also wouldn't work, and we are already root, so the sudo is useless, but I did that(with my own way) and it only solved the first part. But not the whole thing. Thanks anyway. – Farid Nouri Neshat Jun 16 '12 at 4:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.