Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just tried out Parallels 7 for running Ubuntu 12.04 LTS, and encountered a few problems. These are:

Unrecognized Platform

The first problem I have encountered is that Parallels 7 does not recognize Ubuntu 12.04 LTS Server (64 bit) or Ubuntu 12.04 LTS Desktop (64 & 32 bit). I have to manually select "Ubuntu" from the list of platforms.

No fast-track installation

I also noticed that there is no "fast-track" installation of Ubuntu that bypasses all the installation screens. This may be a bug because the Ubuntu version is unrecognized, or perhaps strictly want of a feature. However, I had expected there to be feature-parity with vmWare Fusion 4.

No Parallels tools installed

None of the tools for Parallels were installed automatically (which is kind of expected given the lack of platform support). It was not apparent where they go or how to run them from the installation. When I run Virtual Machine -> Install Parallel Tools ... nothing seems to be mounted in the VM - /dev/fd0 returns "is not a valid block device" and there is no /dev/cdrom or equivalent in fstab; it was not apparent how to mount the install tools. Parallels indicates that it is mounted as device SATA 0:2, but I do not know offhand how to go about tracking this down in /dev.

No bridged networking

For no apparent reason Bridged networking does not work at all. A Google search indicated that this was a known problem.


All of the above may stem from the first issue: lack of platform support. Perhaps these are individual and discrete issues. Nevertheless, I encountered them all within minutes of downloading and installing Parallels 7, so I though to raise them here to see if they have been addressed.

As some context, I was a vmWare 3 user that clicked on the free trial of vmWare 4. Since vmWare 4 did not seem to offer any particular benefits over vmWare 3 I wanted to "downgrade" back to my licensed version of vmWare 3- but this proved to be problematic. As a result, I wanted to give Parallels a try. At first glance, Parallels 7 seems to be snappier than vmWare and seems to use fewer resources, however the above issues make it appear to be less polished. That's my 2ç contribution to the glut of vmWare v Parallels comparisons. :)

Any thoughts on the above issues would be greatly appreciated.

Thanks for reading!

share|improve this question
    
To be honest, I don't think your q has much to do with Ubuntu and would be better if directed to the bugs/features support at Parallels. –  izx Jun 27 '12 at 16:28
1  
@izx: I appreciate that sentiment and you may be right in the sense that is where the expertise lies. However, between here and the Parallels forums, this is a decidedly better forum for expertise on Ubuntu on Parallels because the Parallels forums are largely Windows centric. There are also, I note, almost 500 questions on vmWare here on askUbuntu, so Parallels questions seemed fitting as analogous. –  Brian M. Hunt Jun 27 '12 at 16:46
    
I agree Brian, but I suggest you edit your question and restrict it to questions of the form "how do I do x in Ubuntu on Parallels", etc. instead of "Why won't Parallels do x for me automatically when installing Ubuntu while VMWare will?" as those are clearly questions not for any forum but for the engineers at Parallels. –  izx Jun 27 '12 at 16:54
    
@izx: Good suggestion, thanks. –  Brian M. Hunt Jun 27 '12 at 17:43

2 Answers 2

It all seems to be working with the latest version of Parallels 7 (August 3rd - ParallelsDesktop-7.0.15106.786747) that I just downloaded. I'm guessing that it just took a few revisions for the Parallels developers to catch up with the changes to the new version of Ubuntu.

share|improve this answer

I successfully installed Ubuntu 12.04 LTS Desktop (64 bit) using the Fast Track installation but I had to complete the installation manually (by choosing 'Installaion -> Complete Manually...') so that Parallels would exit the installation process.

I downloaded the Ubuntu iso image and physically burned a CD, then pointed Parallels at it and chose the Fast Track installation.

I then also successfully installed the Parallels Tools. I had to first unmount the current CDROM device. The Parallels Tools disk image is mounted at /media/Parallels Tools. So

cd /media/Parallels\ Tools
sudo ./install

brings up an installer window. Use space or return to proceed through the prompts, then reboot.

I am using Shared Networking, though. So no help there, sorry.

share|improve this answer
    
Well it's late 2013 and I have parallels 9, this is still not working and I have not been able solve this problem myself. Anyone else out there who might have gotten a way to the Parallel Tools without resorting to physical media? –  ken Oct 15 '13 at 13:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.