Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu 10.04.4 LTS, and in my laptop there is a Broadcom BCM4312 WLAN card.
lspci output:

04:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)  
    Subsystem: Broadcom Corporation Device 04b5  
    Flags: bus master, fast devsel, latency 0, IRQ 18  
    Memory at f4500000 (64-bit, non-prefetchable) [size=16K]  
    Capabilities: [40] Power Management version 3  
    Capabilities: [58] Vendor Specific Information <?>  
    Capabilities: [e8] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-  
    Capabilities: [d0] Express Endpoint, MSI 00  
    Capabilities: [100] Advanced Error Reporting <?>  
    Capabilities: [13c] Virtual Channel <?>  
    Capabilities: [160] Device Serial Number 81-ac-1d-ff-ff-12-54-92  
    Capabilities: [16c] Power Budgeting <?>  
    Kernel driver in use: wl  
    Kernel modules: wl, ssb  

So as you can see, the current (and default) driver is wl - installed with Jockey.
But I have another Ubuntu based distribution on my laptop (BackTrack linux), which is also 10.04, but it has the b43 driver installed and the overall performance is much better. So I would like to install it on this OS too, but even google didn't help me.

So my question is how to install the latest b43 driver on my Ubuntu?

share|improve this question
    
How is it in ubuntu 12.04? the aim is to activate the possibility of an Accesspoint - b43 would support this... wireless.kernel.org/en/users/Drivers/… wireless.kernel.org/en/users/Drivers/b43#Ubuntu.2FDebian - the hardware must be able to do this because under windows i can use the trial version of connectify.me and my android phone recognize the wpa-wifi-accesspoint but not the wep-accesspoints made by ubuntus networkmanager... that's realy interesting –  user154244 Apr 30 '13 at 22:13
add comment

1 Answer

up vote 0 down vote accepted

Type in a terminal:

sudo apt-get install b43-fwcutter

Under the desktop menu System > Administration > Hardware/Additional Drivers, the b43 drivers can be activated for use.

Restart.

Edited:

Install dkms.deb, patch.deb, fakeroot, and bcmwli. Those packages are in Ubuntu installation CD in the following paths:

/pool/main/d/dkms.deb
/pool/main/p/patch.deb
/pool/main/f/fakeroot
/pool/restricted/b/bcmwli 

Enable STA driver in additional driver.

sudo modprobe -r b43 ssb wl
sudo modprobe wl
share|improve this answer
    
b43-fwcutter is already installed, but still it isn't in use. And jockey-gtk only shows the current STA driver. "These package contains Broadcom 802.11 Linux STA wireless driverfor use with Broadcom's BCM4311-, BCM4312-, BCM4321-, andBCM4322-based hardware." –  Laszlo Boros Jun 11 '12 at 10:09
    
Is it not listed in Additional Drivers? What does sudo modprobe b43 give? –  jasmines Jun 11 '12 at 10:17
    
Nothing. Absolutely nothing :/ –  Laszlo Boros Jun 11 '12 at 11:13
    
Try with my last edited version of the answer. –  jasmines Jun 11 '12 at 11:32
    
Ok, now it worked! Thanks for Your help!!! I installed those packages from the CD, but I deactivated the STA driver (You sad to activate), and I wrote sudo modprobe b43 instead of wl, and now it works. Thanks again! –  Laszlo Boros Jun 11 '12 at 12:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.