Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to ubuntu server and i have installed ubuntu server on a vm and installed LAMP etc but my problem is that my website is not visible outside.

i have port triggering and added port 21,22 and 80. i really don't know what am doing, i am totally lost! I have a dynamic ip but i can access the server through 192.168.25.1 no matter how many times i restart the modem and from my public ip.

I get redirected to my router settings what should i do??

I am able to listen to all my ports

tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN
tcp 0 0 192.168.25.129:22 192.168.25.1:46599 ESTABLISHED tcp6 0 0 :::110 :::* LISTEN
tcp6 0 0 :::143 :::* LISTEN
tcp6 0 0 :::22 :::* LISTEN
tcp6 0 0 :::25 :::* LISTEN
tcp6 0 0 :::993 :::* LISTEN
tcp6 0 0 :::995 :::* LISTEN

share|improve this question
    
can you access you site from a machine in your LAN? and can you ping your machine from outside your network, I mean from WAN? –  Vineet Menon Jun 11 '12 at 9:32
    
i tried proxy servers but it didn't worked –  Keshav Nair Jun 11 '12 at 11:20

2 Answers 2

up vote 2 down vote accepted

I see that you are getting your router's config page, and this means that your port 80 is not forwarded. Also, you can access it from 192.168.25.1 as that IP is inside your network and never changes(Think of an apartment building that moves around and has its street address change but the apartment numbers are constant). Consider http://freedns.afraid.org to give your network a constant domain name. There is a dynamic DNS link there that gives you a small shell script you can run from a cronjob.

Please enter your router settings and try to use an option like "Port Forwarding" or "Enable Applications". Do not use port triggering. Use static port forwarding. From here, the process is very dependent on you router, so consult its instructions for more help. You can forward the following ports:

  • 80 for HTTP
  • 22 for SSH
  • 443 for HTTPS, if you have a certificate you are using it with
share|improve this answer
    
I don't have port forwarding option but can i use virtual server and in the ip do i have to add 192.168.25.1 and i don't have a static ip but i don't know why but it remains the same always –  Keshav Nair Jun 11 '12 at 17:40
    
Your dynamic IP is your external IP. Set up virtual server with the proper ports(to 192.168.25.1), and get an account at afraid.org. You can then use the dynamic DNS wget script and a cronjob to get a permanent domain name. –  hexafraction Jun 11 '12 at 17:44

most of the internet service providers doesn't allow traffic from outside in this case you may not be able to access your machine from outside,if your isp allows you and if you are able to do ssh or telnet from outside, please check the port status by using the command netstat -nta and check whether your server port is listening on 192.168.25.1 or 0.0.0.0

share|improve this answer
    
Yes it says listen i will edit my question –  Keshav Nair Jun 11 '12 at 11:29
    
are you able to do ssh from outside? –  abhilash Jun 11 '12 at 11:45
    
No ObsessiveFOSS said it right ports were blocked by my router –  Keshav Nair Jun 11 '12 at 17:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.