Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Right after the Ubuntu Installer finishes installing Ubuntu, it prompts me to reboot the system.

It boots up and loads the Ubuntu loading screen with the dots, then it says it's preparing for first use.

But, then it froze and the dots stopped moving. It's been like this for a good 10-15 minutes.

Is it still installing or did something went wrong?

System Specifications:

  • Model : Dell Inspiron 530 Mini Tower.
  • Intel Celeron 450 @ 2.4 GHz processor
  • Intel Integrated G33 Family Chipset graphics

Note: I've also installed previous versions of Ubuntu which worked flawlessly on PCs with worse specs than this.

Other info - I'm attempting to install this alongside (triple-boot) Windows 7 and Windows 8.

share|improve this question
Something problematic must be going on... Once Ubuntu prompts for reboot it means that it has been fully installed. after reboot it directly comes to desktop. I am afraid it your installation dist is carrying some defects post you burnt the downloaded iso. Kindly verify the checksum or run the option "Verify disk for errors" – Z9iT Jun 11 '12 at 7:50
You should not go for triple-boot. it is highly risky unless you are mere experimenting with the OS'es. I strongly suggest you not to triple-boot. Rather you may use some virtualization software like Oracle VirtualBox for multiple OS. – Z9iT Jun 11 '12 at 8:03
I figured out that it was a firmware error, and I needed to add b43 to the blacklist while in the GRUB menu. And yes, I know Triple Booting is highly risky when it comes to the loss of system files/instability. Thanks for the answers! [CLOSED] – Collin Jun 11 '12 at 8:17
@Z9iT sorry for this question, but please tell me why it is not good to have triple boot? because I am using triple boot right now (ubuntu 10.10, kubuntu 12.04,windows XP) and going to add two more OSes later (windows 8, Ubuntu 12.04 or fedora) – Prasad RD Jun 11 '12 at 11:30
@Prasad you may "ask a new question" regarding this and i would love to share my experience with you. This will be also helpful if the community may pool their knowledge. I am afraid since it is not a mainstream question, it might be added to meta site. – Z9iT Jun 11 '12 at 14:58

I have a triple boot myself (vista, ubuntu 11.04 and ubuntu 12.04). The problem i encountered was the same as yours. On the grub menu choose ubuntu 12.04, press e, look for the line "quiet splash", and change it to "quiet splash nomodeset", and continue with booting. If this solves the problem you have tot do this modification permanently as root with changing the grub file in /etc/default/grub with the same modification. Do not forget a sudo update-grub afterwards.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.