Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Nvidia Ge force Ge6150 SE graphics card. I am running ubuntu 12.04. When I try to install the .run file it fails. It shows the message like this:

enter image description here

I Itried to install it after uninstalling the old driver.still same message. here is the log file.

nvidia-installer log file '/var/log/nvidia-installer.log' creation time: Mon Jun 11 05:46:17 2012 installer version: 295.53

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

nvidia-installer command line: ./nvidia-installer

Using: nvidia-installer ncurses user interface -> The file '/tmp/.X0-lock' exists and appears to contain the process ID '1062' of a >runnning X server. ERROR: You appear to be running an X server; please exit X before installing. For >further details, please see the section INSTALLING THE NVIDIA DRIVER in the README >available on the Linux driver download page at ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' >for details. You may find suggestions on fixing installation problems in the README >available on the Linux driver download page at

but no such file is shown in the process manager. Help me!!

share|improve this question
Does installing the nvidia-current package in ubuntu with apt-get not work with your card? Why are you trying to install that version of the driver, rather than the supported version packaged for ubuntu 12.04? – dobey Jun 11 '12 at 1:05
It has problems with my card.It conflicts with unity.Glitches in video playback .Nvidia Current is still 295.40!It do not give me the resolution 1440*900 – Kiranraj Jun 11 '12 at 1:20

10 Answers 10

As the error states, you are still running an X server. This error occurs when you try to install the Nvidia .run files while logged in.

Make sure you are logged out.

  • Hit CTRL+ALT+F1 and login using your credentials.
  • kill your current X server session by typing sudo service lightdm stop or sudo stop lightdm
  • Enter runlevel 3 by typing sudo init 3 and install your *.run file.
  • You might be required to reboot when the installation finishes. If not, run sudo service lightdm start or sudo start lightdm to start your X server again.
share|improve this answer
I only see a blank, black screen when trying to access the tty terminals. How should I go about installing the drivers? – Kevin Wheeler Aug 18 '15 at 6:44
This made my laptop unusable. I boot successfully into the login screen, but when I login to any account, I see a black screen for a second and I am back at the login screen... any idea what's going on or how to resolve it? :( – user1111929 Feb 11 at 14:41
This happened to me on my GT220 card, updating to nvidia 340. Apparently, the card is not supported by the latest driver. You may try going down a version or two until you have a usable desktop. Good luck! – Rey Leonard Amorato Feb 12 at 15:12
"Enter runlevel 3 by typing sudo init 3 and install your *.run file" can you please clarify how to install the .run file? – Kalamalka Kid Jun 10 at 7:03
Once you've managed to enter runlevel 3, you can simply type <path to your *.run file> and execute. The installer will guide you through the process. – Rey Leonard Amorato Jun 20 at 6:49

I installed latest nvidia drivers by this method:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

It is working fine with unity 3d. Thanks to all.

share|improve this answer
it's not clear if this gets around the problem of trying to install the driver while an X server is running. – amc Aug 1 '13 at 7:33
This doesn't fix the X server issue when trying to install the .run file, but it does offer another way to install/update to the latest nvidia drivers packaged for the unbuntu distro. – Felby Jan 12 '15 at 22:49
The driver this serves up is many versions outdated. Is there a way to get the actual current version through apt-get? – schwiz Mar 20 '15 at 19:40
I strongly not recommend this method. It made my X server to refuse to start on system start, I had to remove it on console mode. It seems that those drivers are now very outdated and not updated anymore. – Aracthor Oct 28 '15 at 1:45

Add the --no-x-check flag when you run this in the terminal:

sudo ./ --no-x-check
share|improve this answer

This instructions Works great under ubuntu server 12.04 with ubuntu desktop for nvidia 8400GS PCI 512MB too just need to unistall all previous versions of default versions under ubuntu like 173 etc or any other before installing or there will be conflict or crash. Follow this tread instructions + read me install info from your card model example in my case latest driver version 319.23, see link below:

share|improve this answer
please provide a summary of the steps required in addition to posting a link – amc Aug 1 '13 at 7:35

it says you are running an X server, meaning a graphical desktop. Try this:

CTRL+Alt+F2 to open a terminal session. Try running the from here then.

share|improve this answer
When I pressed CTRL+Alt+F2 monitor shows "out of range".how to get rid of this? – Kiranraj Jun 11 '12 at 1:50
@user69815 That shouldn't happen, generally, but may be due to the kernel driver setting the wrong frame rate or something on the frame buffer. If it is, I would think it may go away after installing the newer driver and rebooting, assuming it does support your card. Also, it is worth pushing for the updated driver to get released as an update for 12.04. – dobey Jun 11 '12 at 17:58
But how can I install the driver without entering the screen after pressing CTRL+Alt+F2? – Kiranraj Jun 12 '12 at 0:00

I had a hangup installing the 3.19 driver today because I did not remove the existing 3.13 driver. I used:

apt-get remove nvidia*

to get rid of all existing files, then

telinit 3
sh NVI*.run

Success. I already had DKMS installed, and the driver program asked if it should use DKMS, so no worries about kernel upgrades.

share|improve this answer

Try this :

  • Alt+F1 then login,
  • sudo telinit 3 (if that isn't work try /sbin/telinit 3), and check that it is changed to level 3 with runlevel that should output something like 5 3 which means that the current run level is 3 and before it was 5.

In case that doesn't work, try:

ps ax | grep X

In the output you would see the PID number of the process X, so you should kill it with sudo kill -9 number where number is the PID number of the process.

share|improve this answer

I tried all of these things and none of them worked for me, because I kept getting a Stop: Unknown instance error when I ran "sudo stop lightdm". I finally killed the x server by going into the lightdm log and finding its process number, then killing it that way:

  1. cd /var/log/lightdm

  2. open the .log file (you may need to use sudo to do this)

  3. look for something in the file that says "launching process 'process number'"

  4. sudo kill -9 'process number'

Good luck!

share|improve this answer

I want to add my answer here because I couldn't install the NVidia driver, I couldn't get tty working and I wasn't able to install it in safe mode root shell. What I did was a combination of two answers here:

NOTE: before doing this, be sure that the NVidia driver is already downloaded and in an accessible directory.

For reference, I have NVIDIA GEFORCE GTX 750 TI and the following worked for me: Installing the generic Nvidia driver will get tty working, do this with:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current 

Now you won't be able to get past the login screen in Ubuntu, but that's OK. Restart the computer and once you are brought to the sign in screen go to tty1 [ ctrl + alt + f1 ]. Now do the following commands:

sudo service lightdm stop
cd <path/to/NVIDIA>
sudo sh ./NVIDIA*

Follow the prompts and viola. After restarting everything should be working fine and dandy.

share|improve this answer

I had the same problem installing the driver for an old GeForce 9800 GT in Ubuntu 14.04-2. It was the

I switched to the the tty1 using Ctrl+Alt+F1 and also stopped the service lightdm and when running the executable got the same error .

What I did to solve the problem was navigate to the /tmp folder and erase the .X0-lock file.

You will only see it listed if you use ls -la as it is a hidden folder by default(that is why it has a dot in front of the name)

cd /tmp
rm -rf .X0-lock

After erasing that folder and executing the it installed just fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.