Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to set up my internet connection and router with Ubuntu 12.04 and I've been having some issues. I am currently trying to connect directly through my modem using the PPPoE username and password provided by my ISP. I ran sudo pppoeconf and input my information but was still unable to connect.

Furthermore, my computer is now unable to connect to my wired network and upon startup spends about 5 minutes configuring network options before allowing 60 seconds to complete its task and eventually booting without all networks properly configured.

I am new to Ubuntu and Linux and any beginner friendly help that you could provide would be greatly appreciated.

EDIT: I am still unable to connect to the internet and I've grown to accept that Ubuntu won't successfully interface with my Japanese modem, but I was wondering if there was any way to avoid the 'configuring networks' delay on boot that I have been experiencing.

share|improve this question
    
Have you tried using your (ADSL?) modem to handle PPPoE (or PPPoA) instead? –  david6 Jun 11 '12 at 0:23
    
My internet connection is fiber optic and since I ran sudo pppoeconf in the terminal, my computer hasn't been able to recognize the LAN cable from my modem. –  Dan Jun 11 '12 at 5:10
    
Also, I'm in Japan so my internet service is a little strange. Internet access and a modem is provided by one company while my actual ISP that provided me with a PPPoE username and password is a completely differeny entity. I don't know much about computers, but from what I understand I need to set up the PPPoE information on my PC and have internet working straight from the modem before I can setup my router. –  Dan Jun 11 '12 at 5:13
    
What does Network Manager have as status, for your connection? –  david6 Jun 11 '12 at 5:33
    
I'm at work now but I'll check as soon as I am able. Thanks for the help! –  Dan Jun 11 '12 at 5:46
show 1 more comment

2 Answers

It's quite simple. Just click on the NETWORK icon on top right. Click EDIT ...... and in that, go to DSL tab. and click for NEW. You will bhave 4 or more tabs. go through each of them. and only fill the information which you know. and in the mac address field select your own mac address. Good Luck,.

share|improve this answer
    
I clicked the Network tab and found no DSL connections to edit so I created one an filled in the PPPoE information provides by my ISP. After saving the connection, however, my computer still does not recognize the presence of my LAN cable and I am unable to connect to the internet. –  Dan Jun 11 '12 at 10:44
    
Delete all connections from the wired tab and edit the dsl connection you just made. EDIT= set it as connect automatically. –  silenTK Jun 11 '12 at 15:15
    
I don't seem to be able to delete the one wired connection but I changed the settings on the DSL connection but I was unable to establish the DSL connection even after rebooting. It asks for DSL authentication and the password and username my ISP provided aren't working. –  Dan Jun 14 '12 at 10:38
add comment

You need to look at:

network manager says “device not managed”

Although, I am not sure this is an instant fix or anything ..

share|improve this answer
    
Thanks David, I followed those instructions and my system now recognizes the modem; however, I still can't connect to the internet. Should I try adding my PPPoE information to the wired network "ifupdown(eth0)"? Nevermind, it seems I can't edit that connection. Any advice on how to proceed? –  Dan Jun 11 '12 at 11:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.