Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Lenovo U400
Wine 1.5.5
Ubuntu 12.04 with all updates applied

I'm experiencing severe (~500ms) audio lag in all games run in Wine. Portal 2, Half-Life, World of Goo, and Fallout are all exhibiting this problem. When I run winecfg though and click the "Test Sound" button at the bottom of the Audio tab, the sound effect appears to play immediately. So I'm not sure what's going on. I don't think it's a problem with PulseAudio by itself since totem videos and Youtube clips both play in perfect sync.

Anyone have any ideas on where to start fixing this? thanks!

(edit: I thought this was limited to Steam games but I installed a non-Steam game and I now see that's not the case. I get audio lag in other apps too.)

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

I disabled PulseAudio by setting the environment variable WINENOPULSE=1 and Wine apps seem to work fine now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.