Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Intel corporation core processor integrated graphics controller (rev 18), and I am trying to get a proprietary driver for my graphics card so I can play Amnesia from the Humble Bundle.

I am a female that can easily follow directions but doesn't know much about Linux yet. If you give me precise directions, I will follow them so you can help me fix the problem. I would really appreciate it!

My laptop is a Dell n7010.

Additional info: I believe that it is the graphics card that is causing Amnesia to crash, but I am unsure. I have tried running it on the lowest possible settings, and it crashes after the first loading screen. :(

Also, I installed via the Ubuntu Software Center after purchasing the Humble Bundle. I have not tried the other games yet.

share|improve this question
which version of ubuntu do you use? perhaps updating your drivers helps (…) – offline Jun 10 '12 at 21:18
I am currently following the terminal directions now. I use ubuntu 12.04 – user69798 Jun 10 '12 at 21:40
Welcome to Ask Ubuntu! Can you provide us with more information about the crash you are experiencing, if possible? This information often can be found by running the affected program from the terminal and then copy-pasting the output as either a code block in your question or as a link to a paste at – Christopher Kyle Horton Jun 10 '12 at 21:40
Related (possible duplicate?): – Christopher Kyle Horton Jun 10 '12 at 21:41
I am so sorry, but can you show me how to run amnesia from terminal? I copied the entire file to my desktop. what code should I put in the terminal? – user69798 Jun 10 '12 at 21:42

My laptop also uses Intel graphics (it is a Toshiba Satellite model), and it does not use proprietary graphics drivers. The reason for this is because the official Intel drivers for Intel graphics are themselves open-source; thus no proprietary drivers are available.

If you continue to have issues running Amnesia that appear to be graphics-related, then the issue is most likely with the game itself having a bug.

Relevant links:

share|improve this answer

I was able to get my Intel Sandy Bridge working.

First you need to have mesa-utils installed

you need need the s3tc library installed, it allows the texture compression needed by mesa

search for and install


in the Software Center.

If you card can support it, the game will launch. There are several quality selections in the launch window that comes up so you can try low if medium doesn't work. Medium works for me, I haven't tried High as Medium is very nice.

I can tell you that apport seems to think that your gpu hangs so you may get the "System error encountered" box popping up but I had no hangs except when apport was gathering information and after I removed

apport, apport-gtk, apport-symptoms 

I have been playing with no problems for the last 3-4 days. So if you can get it working you may have to uninstall those progrmas or disable apport to play without interruptions.

As was said in another answer there are no propriety drivers for Intel, at least not that I know of either.

{edit} If you tell the launch window for Amnesia to detect your card it will tell you it's unsupported but as I said it is working fine on my Intel.{edit}

share|improve this answer

Intel drivers are in kernel by default, if you need hardware acceleration on movies via VLC the you need to install libva-intel-vaapi driver via USC. In case you want the very latest from git then add oibaf ppa at

On my system with the drivers from this ppa and sna enabled via xorg, it works quite well.

share|improve this answer

Your proprietary drivers should be just a click and install through the Additional Drivers program.

share|improve this answer
The only driver it shows is the broadcom sta driver, no matter how many times I try to update it. – user69798 Jun 10 '12 at 21:37
I use ubuntu 12.04 – user69798 Jun 10 '12 at 21:38
Broadcom is the proprietary driver for your wireless card, not the graphics. It won't be much use here. – Christopher Kyle Horton Jun 10 '12 at 21:42
I agree, just thought I'd let you know that no additional driver options show up. – user69798 Jun 10 '12 at 21:43
Intel makes open source drivers--so you don't need to enable proprietary drivers for it, the OEM drivers are included in the kernel (well as long as you have a recent kernel). – adempewolff Aug 22 '12 at 10:45

This guide will show you how to get new drivers via the GUI or in Terminal. Its from Ubuntu Proprietary Drivers

share|improve this answer
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Peachy Sep 29 '12 at 5:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.