Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

In Rhythmbox's Preferences, you can change the "Preferred Format" for Music to MPEG Layer 3 Audio, Ogg Vorbis, FLAC, or MPEG 4 Audio. However, despite there being a Settings button, it does not become enabled for any of these choices. (I have installed all of the gstreamer plugins, but this has made no difference.) So how can you change the "Preferred Format", for example to change the bit rate or the quality setting?

share|improve this question
This seems to be a known bug: bugreport I have the same problem, but no solution so far. – user70763 Jun 15 '12 at 8:50
@preiaen Thanks, that link provided me enough information to work out a solution. – user8979 Jun 23 '12 at 10:00

2 Answers 2

up vote 5 down vote accepted

The following demonstrates how to modify the settings for the preferred format "Ogg Vorbis":

Create a GstVorbisEnc.prs preset file:

$ sudo gedit /usr/share/gstreamer-0.10/presets/GstVorbisEnc.prs


The [Default] section contains the settings for the "Default" preset. The example I have given above is for 0.6 quality (~192kbps) VBR encoding. The default is 0.3 (~112kbps). Quality can be set from -0.1 to 1.0. There is further information on these settings at

Now add the line "preset = Default" to the [streamprofile-oggvorbis-1] section in rhythmbox.gep:

$ sudo gedit /usr/share/rhythmbox/rhythmbox.gep
parent = oggvorbis
type = audio
format = audio/x-vorbis
presence = 1
preset = Default

And this demonstrates how to modify the settings for the preferred format "MPEG Layer 3 Audio":

Create a GstLameMP3Enc.prs preset file:

$ sudo gedit /usr/share/gstreamer-0.10/presets/GstLameMP3Enc.prs


The [Default] section contains the settings for the "high" preset. The settings above are for 128kbps stereo CBR encoding. There is further information about the possible values at

Add the line "preset = Default" to the [streamprofile-mp3-1] section in rhythmbox.gep:

$ sudo edit /usr/share/rhythmbox/rhythmbox.gep
parent = mp3
type = audio
format = audio/mpeg, mpegversion=1, layer=3
presence = 1
preset = Default

Thanks to preiaen for providing the link that helped me find a solution:

Bug #945987 “No Settings are available in “Preferred format”

This led to the following pages where I found further information:

[SOLVED] How to edit CDRip settings in Rhythmbox - Ubuntu Forums

Linux Format forums :: View topic - Ubuntu 12.04 LTS Released

share|improve this answer

In Rhythmbox go to Edit --> Preferences--> Music --> Preferred format --> then simply select your preferred format from the drop down menu.

Another method would be to change it via pipeline to something like:

audio/x-raw-int,rate=44100,channels=2 ! lame name=enc mode=0 quality=0 bitrate=192 ! id3v2mux

If you need to store tracks in the MP3 format (for example, if your portable music player only supports MP3 and not Ogg Vorbis), you will need to create a new profile. To do this, click on Edit Profiles, click New, and name the profile MP3.

Select the MP3 profile and click the Edit button. Set GStreamer Pipeline to audio/x-raw-int,rate=44100,channels=2 ! lame name=enc ! id3mux

Set the File Extension to mp3, and select the Active check box. You will have to restart Sound Juicer to see the new audio profile.

This profile uses the LAME MP3 encoder, so you will need to have the GStreamer LAME plugin installed.


share|improve this answer
Could you explain how you edit the pipeline in 12.04? – user8979 Jun 17 '12 at 19:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.