Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am not able to launch Netbeans. When I launch it for the first time I normally get the netbeans splash screen, but after that nothing happens. netbeans splash screen

When I try to launch it again, a small blank window appears.

small blank window

I am able to enlarge the window, but it is completely blank.

enlarged window

I am using openjdk-6.

Any ideas? As far as I remember this didn't come after some update/new install or whatever. Netbeans worked perfectly, but then all from the sudden...


When run in terminal:

  • When run for the first time:

$ /opt/netbeans-7.1.2/bin/netbeans

10.6.2012 19:00:26 org.openide.filesystems.FileUtil normalizeFileImpl

WARNING: FileUtil.normalizeFile(/home/tomas/.netbeans/7.1.2) took 569 ms. Result is /home/tomas/.netbeans/7.1.2

Then it just hangs. It doesn't quit, it just stays. If I exit (Ctrl+C) and start over again, I get the splash screen, but then again it hangs.

  • When run again, while another instance is running:

    No output in terminal - just the blank screen.

share|improve this question

Though this is not the "clean" answer, I managed to launch it. This is how I did it:

  • I moved the ~/.netbeans/7.1.2/ folder somewhere else. For example mv .netbeans/7.1.2/ .netbeans/7.1.2x/.
  • I launched the NetBeans, the program asked me, if I want to import my old settings (I've had older versions of netbeans on my computer).

All my settings were as well on the older version, so I didn't lose my settings and the app is working!

share|improve this answer

This same thing happened to me on my Windows7 machine.
The problem was that I 'lost' Java (JRE). Here is what I did:

  1. From this page: Verify Java version , I learned that Java wasn't installed
  2. I downloaded JRE from here: Download Java. You will need to figure out the right version for your machine.
  3. I ran the install.
  4. I started NetBeans. I got this error message:

    Cannot locate Java is specified jdkhome.

  5. Following advice from here: How to Fix NetBeans jdkhome error , I edited netbeans.conf to point to the new Java location.

  6. Everything's alright.

share|improve this answer

Try disabling compiz or running the following in a terminal and then launching netbeans from the same terminal:

export AWT_TOOLKIT=MToolkit

And what is your Java version?

share|improve this answer
The line didn't help. I tried to launch netbeans in Unity 2D (hence there isn't compiz), but no luck. I am using openjdk-6. – tsusanka Jun 10 '12 at 17:24

Similar problem on version 7.2.1. I was able to restore my window to default settings without losing any other config by deleting directory ~/.netbeans/7.2.1/config/Windows2Local.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.