Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a small public internet cafe, with Ubuntu 10.04 and 10.10. I'm using Google Chrome 7.0.517.44 (64615), with AutoScroll - Version: 2.7.5; AdBlock is removed because of high CPU loads, and unconfortable speed of machine.

"Your profile could not be opened correctly" error is displayed: cannot load profile This image is only an illustration.

The reason is that I changed permissions of some config files, to don't remember the history, there are no setting in options, to don't use history.

I've been removed write permission to:

~/.config/google-chrome$ find . -group nopasswdlogin
./Default/Archived History
./Default/History
./Default/Visited Links

When I solved all of my problem, I'll remove some other write permission, this is a public place.

What methods are known to HIDE this message? Thanks!

share|improve this question
1  
Why don't you start chrome in incognito mode instead ? –  João Pinto Nov 25 '10 at 20:42
1  
Why don't you use f.e. guest sessions or sessions which store all data in a temporary place in the first place? –  Bobby Nov 25 '10 at 21:37
    
@João Pinto, thanks, but in the man google-chrome no entry for incognito. How can I do that? @Bobby, is there any tutorial to do that, the computer is auto starts with guest session? –  B. Roland Nov 27 '10 at 9:12
3  
You just need to launch it with: chromium-browser --incognito –  João Pinto Nov 27 '10 at 16:17
1  
Yeah, with google-chrome --incognito, it starts incognito window, thanks! But it isn't solves fully my question..., history thing is now solved, but how to lock the settings? I don't want to someone mess up the settings. –  B. Roland Nov 28 '10 at 18:13

4 Answers 4

up vote 1 down vote accepted
+50

I do not have an exact answer to your question, but maybe a solution for your problem:

chromium can be managed by policies under /etc/chromium-browser/policies/

Have a look at http://www.chromium.org/administrators/linux-quick-start for a short introduction and at http://www.chromium.org/administrators/policy-list-3 for the available settings which you can lock down.

Similar path/links for chrome: /etc/opt/chrome

http://www.google.com/support/a/bin/answer.py?hl=en&answer=187204

http://www.google.com/support/a/bin/answer.py?hl=en&answer=187206

share|improve this answer
    
Hmm, really nice, but I use Google Chrome, instead of Chromium, and there is only configs in my home, but in /etc none :( –  B. Roland Dec 30 '10 at 21:29
    
Added links for Chrome. –  Clausi Dec 30 '10 at 23:02
    
Hmm, very interesting one, for example: SavingBrowserHistoryDisabled, I can turn it off very quickly. Thanks, you solved my question :) –  B. Roland Dec 31 '10 at 8:55

I had the same problem, I solved it by deleting ~/.config/chromium I lost all my bookmark and saved password.

share|improve this answer
    
See google.com/support/forum/p/Chrome/… for reference –  Abhijit Navale Dec 27 '10 at 5:52
    
reread my question, because I said, that I removed some permissions from the config files, to make them unchangeable. –  B. Roland Dec 27 '10 at 10:18

i know you change the permission of that file but the problem is that you have read access of some of your files in the default chrome directory, similar bug here, with no solution at the moment :

the solution must be :

Open a terminal, type this

mv ~/.config/google-chrome/Default ~/.config/google-chrome/Backup

Now run google-chrome, and it should work. Then close it, and type this in your terminal. Code:

rm -rf ~/.config/google-chrome/Default 
cp -R ~/.config/google-chrome/Backup ~/.config/google-chrome/Default

Then when you open it all of your preferences should be back, and everything should be good.

If you want an easier way and don't care about your bookmarks and preferences or anything, or the first solution doesn't work -> you could close it and type this.

rm -rf ~/.config/google-chrome/Default

Then when you open it you should be able to start from scratch.

another option is to make a script that each time a user login in GNOME delete the DEFAULT folder directory and each user would initiate as a clean config

share|improve this answer
    
Ok, I've been tried out, but nothing, your first method is fail here. Sorry, but thanks your time. The script isn't a good method, because it is a public place, no login required, a normal user automatically logs in, when system starts up. If you have an other anwser, please share it with me... –  B. Roland Dec 30 '10 at 20:31

How about using an extesion like No History to stop Chrome from recording browsing history? Instead of changing file permisssions, you may try this way.

If you want, you can even go ahead and edit the files of the extension to disable the button on the toolbar. They are located under the following directory;

~/.config/google-chrome/Default/Extensions/ljamgkbcojbnmcaonjokopmcblmmpfch/1.0_0/

I don't think your visitors will want to disable this extension though. So, you may just left it as it is.

share|improve this answer
    
Yeah thanks, I've been tried this extension, but it doesn't lock the settings of Chrome. And that is as important as the history. I think, if you find(I haven't find) an extension what password protects the settings window(and extensions), that solves all of my problems. –  B. Roland Dec 31 '10 at 8:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.