Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop connected to a second monitor using a vga port. No proprietary drivers used. When I go to System Preferences --> Monitor and I turn that on it doesn't look as it should, and it's rotated 90 degrees clockwise or anti-clockwise. I can't choose Normal on the rotation dropdown menù in the monitor preferences.

I wonder if there is a workaround to make it look normal.

share|improve this question

5 Answers 5

up vote 4 down vote accepted

Ok, just solved it. I typed in the terminal:

xrandr --output VGA1 --mode 1280x1024 --rotate normal

If you have the same kind of problem, you have to change "VGA1" with the right output (just type xrandr in the terminal to have a list of your your video outputs) and "1280x1024" with the resolution you want.

share|improve this answer
1  
Is the --mode option mandatory? Can't I simply tell it to rotate regardless of current resolution? –  MestreLion Jun 14 '12 at 19:56
    
if you don't want to set your resolution manually use --auto instead –  vonValle Jun 18 '12 at 15:25
    
--auto switches to the monitor preferred resolution, which is not the current or desirable resolution. –  MestreLion Jun 20 '12 at 6:53
    
If you don't want to change resolution just set it to the same one you're already on. –  vonValle Jun 23 '12 at 13:26
    
It worked, but as Steve Hanov said, there are some physical restrictions in hardware, so placing both screens aside exceed the restrictions and all GUI breaks. Placing second monitor below or above main one, for my laptop, did the trick, thanks! –  unmultimedio Feb 15 at 22:29

After a fresh install, on my system the laptop screen was rotated 90 degrees. To solve it, I logged off, and selected Ubuntu 2D. I was confused at first because I had been running two screens previously, and had no problems. I remember originally when I connected the monitor to the VGA port, it complained thaT I didn't have enough video memory to run the resolution configuration that I asked for. It told me to switch to Ubuntu 2D. On the fresh install, I had the monitor hooked up to the VGA port -- and it didn't complain this time except rotate laptop screen 90 degrees which was confusing.

share|improve this answer

I found a workaround to this problem after researching and experimenting on it for a couple hours. I have a Acer 22" monitor and an HP Pavilion dv2000 laptop. Here are the steps that resolved the issue for me.

  1. I went into the Menu for the monitor itself (buttons along the bottom of the display) and found the "Wide-Mode" setting and turned it off. At this point the display was still sideways, but in a narrow view that doesn't use the full width of the screen. The display is now centered in the monitor with two black bars on the sides of the screen.

  2. I went into the Ubuntu display properties and selected Mirror Displays. This displayed the same content at the same resolution on both monitors (my primary display being my laptop screen) and set the second monitor display in a normal upright position. This had the same effect on the laptop monitor as on the secondary, in that the display does not take up the full width of the screen.

  3. I then deselected Mirror Displays. This turned off the display mirroring but left both displays in the correct orientation with the same resolution. Now neither display covers the full area of the screen, but at least they do both work! Changing the resolution on either monitor results in an error message, but this workaround will serve the purpose for now.

share|improve this answer

I had this problem just now. It seems that Ubuntu has a limit to how wide the virtual screen can be, so it rotates the second one if that will make it fit under the limit. Try positioning the second screen below the first in the display settings.

share|improve this answer

I managed to work-around this problem from "Displays" (GUI), without having to resort to xrandr, by the following sequence:

  1. mirror (& apply)
  2. turn off laptop's monitor in docking station, whilst leaving (current and low) resolution unchanged (& apply)
  3. finally, ramp up resolution on external monitor to max. (& apply)

Note, though, that this is exactly what I was after:

  • laptop-monitor off
  • external monitor on

which might not be what you're after (but in which case xrandr might do the trick)...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.