Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Due to a graphics card compatibility issue using CrunchBang, I was told that my best option would be to move to 12.04 LTS. I'm trying to get everything configured and personalized the way I'm used to things, but am having some issues with unbinding default Unity shortcuts.

I'm used to having all my shortcuts routed through the super key (T for Terminal, W for Web, Up for increased opacity, and so on). I've followed instructions to install compizconfig-settings-manager, and did an advanced search for all keyboard shortcuts binding to the super key, including the Unity shortcuts, but Unity still seems to listen for that keypress, and thus neither compiz nor the keybindings set up in system prefs -> keyboard receive the commands I give them.

(I did try also to simply change the unity launcher key instead of disabling it as shown below -- neither worked)

I've told Unity to chill, but it won't.

share|improve this question
    
I have a similar issue, but I can't actually bind this button, as it keeps auto switching to disabled. –  DavidYell Mar 21 '13 at 13:49

5 Answers 5

Believe Unsettings will let you do that.

sudo add-apt-repository ppa:diesch/testing
sudo apt-get update
sudo apt-get install unsettings
share|improve this answer
    
That did not have any keybinding settings at all. It also read all of the settings i already had in compiz, showing that the compiz settings are certainly being saved and read from somewhere. –  Tom Thorogood Jun 10 '12 at 16:21
    
Hmm, I used tweak tools for unity 2d and I think it had one. They're similar programs. Sorry you went through all the effort. –  Chris Jun 10 '12 at 16:24

It seems already known bug: https://bugs.launchpad.net/compiz/+bug/950160 To work with solution mentioned Can I define keyboard shortcuts using the Super key? , may be it need to disable Tap_Detection for Super key.

See https://code.launchpad.net/~brandontschaefer/unity/disable-super-tap-detection

sudo nano /usr/share/compiz/unityshell.xml

Add <tap_detection>false</tap_detection>:

 <option type="float" name="panel_opacity">
 ..
     <short>Key to show the Dash, Launcher and Help Overlay</short>
     <long>Holding this key makes the Launcher and Help Overlay appear. Tapping it opens the Dash.</long>
     <tap_detection>false</tap_detection>
     <default>&lt;Super&gt;</default>
 </option>
share|improve this answer

I have tried something and it worked. I did not change all the bindings but some and it did work.

You install the gconf-editor and from the menu you go to EditFind and you search for the string <Super> (With the <> symbols). You choose to search in all key names and key values. Then you browse to each finding and you change the value to something else or you disable it. I would suggest that you keep a log with the changes so that you can make the changes back in case something goes wrong.

I changed the <Super>w to <Super><Alt>p and it worked. You can also leave it blank or write Disabled to disable it.

If you want to reassign the functions to other combinations bear in mind that only the special keys have the <> symbols and you should put all letters in small case. Otherwise it gets complicated. You have to write each combination. It does not grab it automatically.

share|improve this answer

If you don't mind using the numbers, you can put your favorites at top, then hold Super(windows-key) and press the number 1/2/3... for 1st/second/third app.

share|improve this answer

This worked for me on Ubuntu 12.04 precise, without Compiz.

In dconf-editor: con → canonical → unity-2d → launcher and untick the 'super-key-enable' option.

share|improve this answer
2  
The problem with your answer is that it deals with Unity-2D and the question is about Unity 3D. –  RolandiXor Sep 22 '12 at 2:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.