Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am setting up a headless music server based on the minimal Ubuntu image. After having installed the packages


neither my internal soundcard nor the external DAC where detected by pulseaudio, that is pactl list did only list the dummy devices. Several reboots did not change that. The hardware devices are detected properly:

~$ lsusb | grep Texas
Bus 002 Device 002: ID 08bb:2706 Texas Instruments Japan 

~$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)

Following a hunch, I installed vlc with all dependencies. After a reboot, both devices are detected!

~$ pactl list | grep "Sink: alsa_output"
Monitor of Sink: alsa_output.pci-0000_00_1b.0.analog-stereo
Monitor of Sink: alsa_output.usb-Burr-Brown_from_TI_USB_Audio_DAC-00-DAC.analog-stereo

Now I would like to remove VLC again but keep the devices. The question is: which of the many dependencies of VLC enables proper device detection?

And why on earth is it not a dependency of pulseaudio?

share|improve this question
Try installing alsa_utils, and please pastebin the output of lsmod and amixer – izx Jun 16 '12 at 4:49
I purged vlc and now I can not reproduce the problem. Curious. – Raphael Jun 19 '12 at 8:30

Most of the libs at are X libs or other junk unrelated to sound.

Of that list, the vlc-nox dependency is likely to be what fixed it for you. You could probably try just installing that.

However, vlc-nox also has a hefty number of dependencies:

But filtering out the video and codec packages should leave you with a shorter list to look at. I'd probably start with ones that explicitly mention alsa or audio.

share|improve this answer

I had a look at all the dependencies form VLC, at first it seems that none one the main ones are directly connected to the detection of sound cards but when you open the dependencies for vlc-plugin-pulse you can see one important one: libpulse0.

I had system that would not be able to or could not detect the sound card correctly without that package installed. I would bet some money on it that that is the reason everything started working correctly.

Can you test this and report?

share|improve this answer
@Raphael Which of the answers should get the bounty? – Bruno Pereira Jun 19 '12 at 8:36
Can you bounty yourself (to refund)? None of the answers really helped. If that is not possible, Bryce's. – Raphael Jun 19 '12 at 9:07
@Raphael don't care about refunding it, his answer was not on spot but was the most helpful imho. Hope you can find what was the packages needed or that the situation stays solved, anything else ping ;) – Bruno Pereira Jun 19 '12 at 9:26

You could try installing libvlc. This should install the VLC dependencies without actually installing and compiling VLC.

share|improve this answer
That might solve the "problem" of having vlc installed, but does not get rid of all the unnecessary dependencies. – Raphael Jun 14 '12 at 10:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.